[mythtv-users] AverTV DVB-T = no channel lock

Matthew Moore myth-mail at matt-sam.com
Tue Jan 23 08:25:48 UTC 2007

Greetings list,

Long time lurker, first time poster.

I've used Myth for over eighteen months now and absolutely love the  
solution.  So much so, in fact, that I recently purchased an additional  
DVB decoder to compensate for Australian television networks love of  
late-running shows.  This tuner is an Avermedia AverTV DVB-T USB2.0 box.

My problem is that Myth will not see a complete lock when attempting to  
tune any channels.

First up, I can confirm that the unit is correctly tuning and receiving  
the channels.  I've done this via:

./tzap -a2 "nine digital" -r

in one console, then in a second:

cat /dev/dvb/adapter2/dvr0 > test6.ts

This results in a file which will happily play in my media player of  

The card shares the same tuning data as my other two tuners (both PCI  
DVICO) and as such I'm sure that the AverTV is getting the correct  
information from within Myth.

When attempting to watch live television, I change to the tuner in  
question and get a black screen whilst it attempts to wait for a signal.   
My other tuners display the "LMS" progress as they attempt to lock on, the  
AverTV does the "L" portion quite quickly but does not progress to the "M"  
or "S".

This is somewhat confusing as I have verified that the MPEG stream is  
valid - it plays in a media player.

I've tried altering each of the timeout values (tuning delay, signal  
timeout and tuning timeout) and also tried toggling the "Wait for SEQ  
start header" option.

My only guess is the kernel support for this device is limited and perhaps  
Myth is waiting for stream information from the driver.  For example Tzap  
does not receive any SNR information:

status 03 | signal 7e62 | snr 0000 | ber 001fffff | unc 00000000 |
status 1f | signal 7c0e | snr 0000 | ber 00000000 | unc 00000000 |  
status 1f | signal 7e04 | snr 0000 | ber 00000000 | unc 00000000 |  
status 1f | signal 7e80 | snr 0000 | ber 00000000 | unc 00000000 |  

Myth is running .20 from ATRPMS.  Kernel is 2.6.19-1.2895 and I'm using  
the integrated kernel drivers for all DVB cards.

Can anyone suggest how to begin debugging this?



More information about the mythtv-users mailing list