[mythtv-users] Mythbackend Segfault on Delete

Kirk Bocek t004 at kbocek.com
Mon Jan 22 18:06:51 UTC 2007

I tried to enable a stack trace under gdb for mythbackend. I'm not that 
familiar with gdb but I assume it's done through the 'bt' command.

I didn't see any change in the crash text:

2007-01-22 10:01:38.147 MainServer::HandleAnnounce Monitor
2007-01-22 10:01:38.147 adding: beryl.pvt as a client (events: 0)
2007-01-22 10:01:38.172 MainServer::HandleQueryRecordings()
                         Couldn't find backend for:
                         curr : "Thu Jan 18 11:35:00 2007"

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1182845280 (LWP 5263)]
0x0000000000000000 in ?? ()

I also saw a bunch of '(no debugging symbols found)'. I assume this is because 
I am using the atrpms binaries and not compiled source.

Do you have any other thoughts on this crash?

Kirk Bocek

Gareth Glaccum wrote:
> Sorry, mine truned out to be a known easy to fix bug (i.e. update the system 
> to the patch from last week).
> I can't remember, did you provide the stack trace from gdb? Was this a 
> compiled or an RPM install of Myth?
> Can you double check your hosts/nsswitch config an ensure that beryl does 
> lookup correctly if you think that adding it as a client is an issue? I know 
> on my system (because I don't read instructions [who does?]) I had the 
> mistake of localhost.localdomain as my master server (still have this week) 
> and this caused several nasty communications crashes.
> Gareth 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list