[mythtv-users] Seperate video out with PVR-350?

mythtv-users at jaredharvey.com mythtv-users at jaredharvey.com
Sun Jan 21 11:25:19 UTC 2007

Hello Dan and list,

DW> I run it right after lircd in /etc/rc.d/rc.local:

DW> /usr/local/sbin/lircd --device=/dev/lirc0 --output=/dev/lircd
DW> /usr/bin/irexec -d /root/.lircrc

I've been trying a handful of things up this alley, but haven't gotten
it  to auto start correctly. I can get it to start, but irexec doesn't
respond  to  the commands from lirc when I auto start. When I do it by
hand,  it  works,  but it's attached to a /dev/ptsX and not automatic.
Here is my current attempt with /etc/rc.d/local

/usr/sbin/lircd --device=/dev/lirc0 --output=/dev/lircd
/usr/bin/irexec -d /home/mythtv/.mythtv/lircrc

When  I  tried it this way, I had turned off the service lircd. I also
tried  it with the lircd service turned on, and with the first line in
rc.local  commented  out,  but  came  to the same results. I know both
programs  started,  because  they  show up in the process list. I also
tried the irexec line as /usr/bin/irexec /home/mythtv/.mythtv/lircrc &
all had the same problem.

I also tried it as an inittab entry with the following line in inittab

ir:345:respawn:/usr/bin/irexec /home/mythtv/.lircrc

My gut feel is that there is some kind of environment variable or some
kind of a problem with the environment when irexec starts, but I don't
know  what it might be. Perhaps I could write a script that sshes into
localhost then starts it as a user? Not sure what the best approach is.
I'm also not sure what the problem is.

Quick  recap  of my system, P4 1.8GHz Dell Fedora Core 6, PVR-350, OEM
PVR-350 remote and MythTV .20.

Best regards.

 mythtv-users at jaredharvey.com                        HAM KB1GTT

e-mail jared at jaredharvey.com
Web page http://jaredharvey.com

More information about the mythtv-users mailing list