[mythtv-users] Can't tune digital channels after --do-channels-update

Bob Sully rcs at malibyte.net
Thu Jan 18 06:29:49 UTC 2007

OK...since I never got any help on importing my old digital-channel
database back in, I did a re-scan the other night, remapped the xmltv IDs.
 Everything was great at this point - I could watch (and record) all the
digital channels, switching to an NTSC channel (analog tuner) happened
immediatel....all was well, except all the digital channels were still
named  "UNKNOWN xx#y".

So, I ran mythfilldatabase --do-channel-updates to go out and get the
right info from the video source.

(1) I can't tune any of the digital channels - at all.
(2) I have to manually switch ('c') tuners to get the analog channels
(this is a pcHDTV-5500 card with both NTSC and dvb tuners).

What happened???  I deleted all the duplicates in sourceID #1 that I could

This is p*ss*ng me off big-time.  I was so close to having a fully working
setup.  :-(


Bob Sully wrote:
> OK, all of you mySQL gurus...a question (aprdon the long post, but this is
> kind of involved:
> I previously had one video source for my three inputs - I was recently
> advised that this was the wrong way to do this.  So, I set up two new
> video sources, via Zap2It Labs, so I now have three for this pcHD5500
> card:
> (1) Those unencrypted channels which I can get via digital cable on my dvb
> input (this will also be used for firewire later, since they both can only
> be used for unencrypted channels);
> (2) All of the NTSC/analog channels, for the NTSC ("television") input on
> the card;
> (3) All channels in my plan, for the s-video input on the card, from the
> STB.
> My previous channel database took me a LONG time to clean up, as I had to
> map all of the unencrypted digital/HDTV channels from the 400 or so that
> the dvb tuner was able to pick up, most of which were encrypted - these
> latter I went through and deleted.  Those that remained, I had to go
> through and remap to the actual channel numbers (e.g. "Unknown 94#2" may
> have been "KABCDT" (ABC HD) on channel 407.  So, before going to the next
> step, I backed up the whole machine.
> Now...when I fetched channels from Zap2It and ran mythfill database, I now
> had a setup where I couldn't get a lock on any channels on the digital and
> analog tuners - only the s-video - probably because there were overlaps,
> dupes, etc.  So, I wound up wiping the new channel DB completely, then ran
> mythfilldatabase again.  This time, I only had channels from (3) above -
> which was ALL possible channels - but the dvb and analog tuners had no
> channels and couldn't tune anything.  I then did a fetch on (2) in
> mythtv-setup and ran mythfilldatabase again.  Now I have channels from
> sourceIDs (2) and (3), and the analog tuner now works.
> Now, my question is:  How do I reimport the digital channels from my
> original (backup) database back into the new database (so as to get my
> QAM-256 channels back)?
> Thanks very much...Bob
> --
> ________________________________________
> Bob Sully - Simi Valley, California, USA
> http://www.malibyte.net
> http://www.malibyte.com
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list