[mythtv-users] NVIDIA

Tom Greer trgreer at gmail.com
Fri Jan 12 04:53:02 UTC 2007

doug at parkercat wrote:

> Tom Greer wrote:
> > In other words, MythTV (and X) are formatting the output to 852x480 and
> > NVIDIA is scaling it to 1920x1080, then the plasma TV scales the image
> > back to 852x480.
> If I were you I'd put:
> Option "UseEDID" "FALSE"
> in your xorg.conf as described in the nVidia README.txt. Then your
> 852x480 modeline should be in effect. This should give you the best
> picture quality.
> Note that the pixel size of the video output has very little to do with
> MythTV's CPU consumption -- we have to decode the full frames of the
> video at full size, then the video card does appropriate scaling.
> -Doug


Thanks for posting to my post (which appears to have been hijacked).

I've started down this road.  Unfortunately, when I insert this, X rejects
all of my modelines and defaults to 640x480.  I haven't figured out why
yet.  I've loaded the HorizSync and VertRefresh settings from my owners
manual.  The log files simply tell me:

 (WW) NVIDIA(0): No valid modes for "852x480"; removing.
 (WW) NVIDIA(0): No valid modes for "ATSC-1080-60i"; removing.
 (WW) NVIDIA(0): Unable to validate any modes; falling back to the default
 (WW) NVIDIA(0):     "nvidia-auto-select".
 (WW) NVIDIA(0):
 (II) NVIDIA(0): Validated modes:
 (II) NVIDIA(0):     "nvidia-auto-select"
 (II) NVIDIA(0): Virtual screen size determined to be 640 x 480

I'm sure that I'm doing something wrong in my xorg.conf; but I can't see
where.  Here are the monitor, device and screen sections:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Panasonic"
        ModelName    "42in EDTV"
        HorizSync    15.7 - 45.0
        VertRefresh  60.0 - 60.0
        Option      "ExactModeTimingsDVI" "true"
        Option      "ConnectedMonitor" "DFP"
        Option      "UseDisplayDevice" "DFP"
          # Native resolution on this TV is 852x480
        Modeline    "852x480" 33.07 852 872 912 1068 480 483 488 516 -hsync
        ModeLine    "ATSC-1080-60i" 74.2 1920 1960 2016 2200 1080 1082 1088
1125 interlace
        Option       "dpms"
        Option      "UseEdidDPI" "FALSE"
        Option      "DPI" "100 x 100"

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        Option      "NVAGP" "2"
        Option      "XvmcUsesTextures" "True"
        Option      "UseEvents" "True"

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport  0 0
                Depth     24
                Modes     "852x480" "ATSC-1080-60i"

Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070111/e1694af8/attachment.htm 

More information about the mythtv-users mailing list