[mythtv-users] Trouble moving backend database to new hardware

Matt Rude mythtv at mattrude.com
Thu Jan 11 18:33:46 UTC 2007

ryan patterson wrote:
> I assume the root cause of the error is because of slightly different 
> versions of mythtv between old/new installs.  But I'm not sure which is 
> older and which is newer.  My old setup was running knoppmyth which is a 
> distribution based on debian that automatically sets up mythtv.  I think 
> I was running .20-fixes  It is possible that the mythtv version in the 
> Edgy repository is actually older.  This might be a deal breaker.  I'll 
> experiment some more too see if I can get it to work.
> On 1/11/07, *Adrian* <642040 at gmail.com <mailto:642040 at gmail.com>> wrote:
>     On 1/11/07, ryan patterson <ryan.goat at gmail.com
>     <mailto:ryan.goat at gmail.com>> wrote:
>      > I am trying to upgrade my mythtv setup.  I am moving from a
>     debian install
>      > to a ubuntu install.
>     I am just about to do the same, so I was reading this thread
>     carefully...
>     Could the problem be that you are migrating from an older version of
>     Myth to a newer version?  If that is the case, the database structure
>     is likely different.  I think that the instructions that you were
>     following assume that you are migrating from and to the same
>     version...
>     Sorry, I am not sure of the best way to recover?
>     Adrian

I beleave you are trying to downgrade from a database that (at lease for 
a time) was running the SVN trunk or the bleeding version of mythtv. you 
  database error talks about storage groups witch is only on the trunk 
(devilment) version at this time (not 0.20). so if your trying to 
install mythtv 0.20 on your new setup I would suggest you only restore 
the tables that you need to restore and no others (but 1st backup and 
wipe your *new* database before you try to restore)


More information about the mythtv-users mailing list