[mythtv-users] Programs not getting scheduled (mythtv 0.20)

Gervase Markham gerv at gerv.net
Wed Jan 10 21:09:37 UTC 2007

Nick Morrott wrote:
> Please could you explain your MythTV setup - number of frontends and
> backends. Your first post in the thread states a combined
> backend/frontend running on a laptop (shrew?), 

That is correct. Both are running on 'shrew' (the smallest known mammal) 
an IBM X40 laptop.

I have in the past attempted to connect to the backend on the laptop 
with a frontend running on another machine on the network, with mixed 
success. But I was not attempting to do so at this time; all those logs 
are from shrew.

> but your logs show:
> adding: shrew as a slave backend server
> which leads me to believe you may either have a misconfigured system,
> or may be running more than 1 instance of mythbackend. In only see
> references to a slave backend when my  real (and separate) slave
> machine connects to my master backend.

I certainly ran more than one "instance" of mythbackend briefly - 
because I ran one as a daemon, and then I ran "mythbackend --resched" to 
reschedule. I understood this was the correct way to do it, because when 
I just ran the resched command without an existing backend running, it 
complained about not being able to connect to the backend. Was I mistaken?

Other than that, it wasn't my intention to run more than one instance. 
And I have run "ps" a few times during the tests - it seems that 
starting up and shutting down mythbackend is a bit hit-and-miss with my 
version on my OS.

I'll have a look around to see if that might be the problem, but some 
further hints would be appreciated. For example, where is the 
configuration which might think I have multiple slaves? How might I 
tweak or fix it to make it match my exact setup?


More information about the mythtv-users mailing list