[mythtv-users] No sound when watching TV

Mercury Morris mercury.morris at gmail.com
Wed Jan 10 15:44:39 UTC 2007

On 1/9/07, Andrew Robinson <awrobinson-ml at nc.rr.com> wrote:
> Anders Pedersen wrote:
> > Hi
> >
> > Hope anybody have a good ide.
> >
> > I've installed the mythtv rpms and the mysql rpms. Initiatet the
> > database but have no sound when watching tv in mythtv. The picture is
> > OK. The TVcard is connected to the soundcard with a cabel.
> >
> I don't know if this will apply at all, but... When I first get into
> MythTV, I will not have sound. So I go into MythMusic and play a song. I
> get sound. Then I go back to "Watch TV" and then I have sound. Since
> this works for me I have never tried to figure out exactly what was
> going on. I suspect is has to do with permissions on the sound device.

Yeah, sound comes online about 30 seconds after the frontend starts,
on all of my MythTV systems.

I've tried unsuccessfully to overcome this mysterious delay by adding a line
to the mythpowerbutton.sh script that plays the KDE startup sound.  This
worked on Fedora Core 3, but now on Fedora Core 5 it doesn't.

Since it's only 30 seconds, and consistently 30 seconds, I've just learned
to live with it.  Annoying as it may be, when I weigh the headaches of trying
to figure out what Fedora is doing with the sound permissions, ownership, etc.,
against beautifully-running MythTV systems, it's a no-brainer.  I just allow an
extra minute after running the mythpowerbutton.sh script before I try to play
a recording.


More information about the mythtv-users mailing list