[mythtv-users] Problems compiling .20 svn

tgate tgate at mypublic.net
Thu Jan 4 05:35:55 UTC 2007

On Jan 3, 2007, at 1:05 PM, mythtv-users-request at mythtv.org wrote:

> In the mythtv source directory do
> ./configure --prefix=/usr/local   ... Add  any other configure options
> you need
> make
> make install (as root)
> if there was no errors change into the mythplugins directory
> ./configure --prefix=/usr/local ... Add any other configure options
> make
> make install (as root)

well, I went back and started over.  I got a little bit farther.  The  
only difference I made was that when it came time to install, rather  
than running "sudo make install", I actually logged in as root and  
then ran make install.

this is how far I got on the plugins...

make[2]: Leaving directory `/home/myth/build/mythtv-svn/mythplugins/ 
cd mytharchivehelper && make -f Makefile
make[2]: Entering directory `/home/myth/build/mythtv-svn/mythplugins/ 
g++ -c -pipe -O2 -fmessage-length=0 -Wall -D_FORTIFY_SOURCE=2 -g - 
DUSE_LIB64_PATHES -fno-strict-aliasing -Wall -W -fomit-frame-pointer - 
usr/lib/qt3/mkspecs/default -I. -I/include -I/usr/kde/3.3/include -I/ 
include -I/include/mythtv -I/usr/include -I/usr/lib/qt3/include -I/ 
usr/include -I/usr/X11R6/include -o main.o main.cpp
main.cpp:29:28: error: ffmpeg/avcodec.h: No such file or directory
main.cpp:30:29: error: ffmpeg/avformat.h: No such file or directory
main.cpp:31:35: error: libmythtv/programinfo.h: No such file or  


%> find /usr/local | grep avcodec.h
%> find /usr/local | grep avformat.h
%> find /usr/local | grep programinfo.h
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070103/5b7ac4d0/attachment-0001.htm 

More information about the mythtv-users mailing list