[mythtv-users] /dev/video0 works UNTIL myth records, video1 works all the time

Justin Walther justin at walthernet.com
Tue Jan 2 16:28:20 UTC 2007

by full framerate, do you mean recording 720x480 instead of the
default 480x480 that mythtv defaults to?  I just tried changing my
recording profiles to 720x480 and I think that just fixed it.  I'm
still testing some more but I'm now recording on both devices.

For what its worth, the ivtv dmesg output was just grep ivtv, not the
full output.  Here it is for card 1:

ivtv1: Autodetected Hauppauge card (cx23416 based)
PCI: Enabling device 0000:06:01.0 (0010 -> 0012)
ACPI: PCI Interrupt 0000:06:01.0[A] -> GSI 22 (level, low) -> IRQ 90
ivtv1: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)
tuner 2-0061: chip found @ 0xc2 (ivtv i2c driver #1)
saa7115 2-0021: saa7115 found @ 0x42 (ivtv i2c driver #1)
msp3400 2-0040: MSP3445G-B8 found @ 0x80 (ivtv i2c driver #1)
msp3400 2-0040: MSP3445G-B8 supports radio, mode is autodetect and autoselect
tveeprom 2-0050: Hauppauge model 32062, rev B185, serial# 7363128
tveeprom 2-0050: tuner model is TCL 2002N 6A (idx 85, type 50)
tveeprom 2-0050: TV standards NTSC(M) (eeprom 0x08)
tveeprom 2-0050: audio processor is MSP3445 (idx 12)
tveeprom 2-0050: decoder processor is SAA7115 (idx 19)
tveeprom 2-0050: has no radio, has IR remote
ivtv1: Autodetected Hauppauge WinTV PVR-250
ivtv1: Encoder revision: 0x02050032
ivtv1: Registered device video1 for encoder MPEG
ivtv1: Registered device video33 for encoder YUV
ivtv1: Registered device vbi1 for encoder VBI
ivtv1: Registered device video25 for encoder PCM audio
tuner 2-0061: type set to 50 (TCL 2002N)
ivtv1: Initialized Hauppauge WinTV PVR-250, card #1
ivtv:  ====================  END INIT IVTV  ====================

On 1/2/07, Rudy Zijlstra <mythtv at edsons.demon.nl> wrote:
> Justin Walther wrote:
> >I do have these lines in modprobe.conf:
> ># ivtv modules setup
> >alias char-major-81 videodev
> >alias char-major-81-0 ivtv
> >alias char-major-81-1 ivtv
> >
> >
> These aliases are OK
> >Do I not need these?!
> >
> >About checking that I'm recording at full frame size...I'm a little
> >lost there.  I'm basically not touching any recording profile settings
> >in myth before attempting to record programs when the card fails.  I
> >thought the defaults would work fine.  Another thing to remember is
> >that my other card works just fine with whatever settings I have
> >setup, including whats in modprobe.conf.
> >
> >
> that what i was thinking, and i had unwatchable video. This on a fresh
> myth install. Swapped the card (PVR500) with a known working card, and
> the problem remained in the new install. Checked the settings, changed
> to full frame capture and my problems were gone.
> I had problems on both tuners of the 500 though. Still, worth trying...
> >I mentioned it at the bottom of my original e-mail about how when I
> >set these cards up a few years go, I had to use different options in
> >modprobe.conf for the cards despite them being identical.  I can't
> >help but wonder if that is somehow related to my current problem.
> >
> >
> Perhaps. Looking at your dmesg, i am also missing the eeprom output
> lines. Are you certain you have all lines between START INIT IVTV and
> >
> >
> >>>
> >>>
> >>Although i see tuner detected messages, i am not seeing any tuner being
> >>set. Also, are you sure you have no ivtv related lines in modconf? There
> >>should be none.
> >>
> >>Furthermore, check that you capture at full frame size, and are not
> >>scaling. A known bug in the current driver range (valid on both 0.8 and
> >>0.9 is that scaling does not work. Or at least vbi and scaling combined
> >>result in problems. For safety i would try to set to full NTSC size and
> >>retry.
> >>
> >>Rudy
> >>
> >>
> >>
> >
> >
> >
> >_______________________________________________
> >mythtv-users mailing list
> >mythtv-users at mythtv.org
> >http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> >
> >
> >
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list