[mythtv-users] Unable to watch long recordings after they've begun

Nick Morrott knowledgejunkie at gmail.com
Mon Jan 1 22:09:50 UTC 2007

On 31/12/06, Ryan Steffes <rbsteffes at gmail.com> wrote:
> I'm having a frustrating problem that seems to have come out of no where; I
> record lots of basketball games, and if I begin watching them shortly after
> they've begun I can watch them just fine, all the way through.  If I wait
> until there's perhaps an hour or so of game recorded already, while it's
> still recording, I can't begin watching it until the recording is finished.
> I've just tried disabling commercial flagging during the recording to see if
> that's somehow messing it up, but I don't have anymore games to record today
> to see if that changed anything.  I can play the file directly, and the
> preview of the file is showing from the selection screen, but if I play the
> recording the screen goes to black for a while, then sometimes the front end
> crashes and shows a segmentation fault, other times it just returns to the
> selection screen.
> I haven't built it with debug flags and tried to run it through the debugger
> (I'm not honestly not entirely sure how) but I pulled last night's svn and
> built it with no change.  It's being recorded on a PVR150, so no fancy HD
> issues, and it's a combination frontend/backend with local file access.
> The log entries I'm getting with '-v most' are as follows:


> 2006-12-31 16:19:34.199 Opening ALSA audio device 'mixed-digital'.
> 2006-12-31 16:19:34.200 Avg read interval was 197 msec. 64K block size
> 2006-12-31 16:19: 34.222 in SetParameters(format=2, channels=2, rate=48000,
> buffer_time=500000, period_time=125000)
> 2006-12-31 16:19:34.224 get_buffer_size returned 4096
> 2006-12-31 16:19:34.224 set_period_time_near returned 21333
>  2006-12-31 16:19:34.224 get_period_size returned 1024
> 2006-12-31 16:19:34.228 Opening mixer /dev/mixer
> ALSA lib control.c:739:(snd_ctl_open_noupdate) Invalid CTL /dev/mixer
> 2006-12-31 16:19:34.228 AudioOutput Warning: Mixer attach error -2: No such
> file or directory
>                         Check Mixer Name in Setup: '/dev/mixer'

If you're using ALSA for playback, shouldn't your mixer be 'default'?


MythTV Official wiki:
MythTV users list archive:

"An investment in knowledge always pays the best interest." - Benjamin Franklin

More information about the mythtv-users mailing list