[mythtv-users] Homebrew Serial Receiver Problems

Greg greg12866 at gmail.com
Mon Feb 26 15:25:48 UTC 2007

Jeremy Gillick wrote:
> Can anybody help me with this?
> - Jeremy
> Jeremy Gillick wrote:
>> Formerly I was using the Hauppage PVR 150 remote, but recently I 
>> decided to move to a custom remote -- the Universal FX1.
>> I followed the circuit designs here:
>> http://lnx.manoweb.com/lirc/?partType=section&partName=circuit
>> The only modification I made was instead of buying a new IR receiver, 
>> I attached a stereo plug to the serial port so I couple plug the 
>> Hauppage receiver into it.  I double checked my work and even did 
>> some basic tests with my workbench power supply.
>> Then I followed the software steps here:
>> http://lnx.manoweb.com/lirc/?partType=section&partName=lirc
>> It's not working.  In fact, the serial port isn't even getting power, 
>> so I assume that it's not active.  I've never messed with serial port 
>> stuff before, so could somebody help me out?   Here are the commands 
>> I tried giving it:
>>     setserial /dev/ttyS0 uart none
>>     depmod -a
>>     modprobe lirc_serial
>>     lircd
>>     mode2  -d /dev/lirc/0
>> FYI: I'm running on Ubuntu Dapper and using the serial port on the 
>> motherboard.
>> When looking through dmesg, here's the only references to lirc -- and 
>> they're still for the Hauppage:
>>     [17179596.772000] lirc_i2c: chip found @ 0x71 (Hauppauge IR (PVR150))
>>     [17179596.772000] ivtv0: i2c attach to card #0 ok
>>     [client=Hauppauge IR (PVR150), addr=71]
>>     [17179596.772000] lirc_dev: lirc_register_plugin: sample_rate: 10
>>     [17179596.880000] Adding 1052216k swap on /dev/hda1.  Priority:-1
>>     extents:1 across:1052216k
>> Am I missing something here?
>> Thanks,
>> Jeremy
>> ------------------------------------------------------------------------
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> ------------------------------------------------------------------------
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-us
Have you checked to see if you have the serial port turned on in your 
bios? Have you tried to test the remote, with typing mode2 in a terminal 
to see if the remote is sending?
   If you are using the Huppauge receiver why not use the port on your 150?
I don't know where you are located,but may be you should buy the parts 
as listed on that site(the Huppauge may need different components to 
work) and get it working and then modify  it to suit your setup....
Not much help, but a few suggestions....
Good luck....

More information about the mythtv-users mailing list