[mythtv-users] Playing wmv on knoppmyth

Nick Rout nick at rout.co.nz
Fri Feb 16 23:45:59 UTC 2007

On Fri, 16 Feb 2007 10:17:13 -0800
Cecil Watson <cwatson at linkline.com> wrote:

> Chad wrote:
> > On 2/15/07, Cecil Watson <cwatson at linkline.com> wrote:
> > 
> >>>Yes I have all of those. I believe the problem must be related to how
> >>>mplayer was compiled by the knoppmyth crowd. I wonder what happens if you
> >>>compile mplayer on a machine without those codecs present at compile time?
> >>
> >>You get the errors you get...
> > 
> > 
> > :D
> > 
> > Excellent response!  Is there a way to override this, similar to the
> > runtime-cpu-detection?
> > 
> > -Chad
> > 
> There is no override (that I'm aware of).  If the codecs weren't
> present, you have to recompile.  If you want MPlayer compiled for a
> specific CPU, recompile.  You can backup and upgrade to R5E50, however
> you'll still need codecs.  In addition, if you want to compile for a
> specify CPU, recompile.  Directions on recompiling to play them all has
> been on the KnoppMyth forum for some time.  Don't like the forum?  Read
> the MPlayer docs.  All dependences (less codecs) are already included.

Thanks, its clear to me now and I have located the thread you mention
on the forum.

It seems to me that the knoppmyth people may be better to compile
mplayer with the codecs present, but not actually ship the codecs,
meaning an dpgk -i w32codecs.x.deb would fix it.

Thanks for the help :-)

More information about the mythtv-users mailing list