[mythtv-users] lirc issues

Josh Pyke josh.pyke at Dartmouth.EDU
Tue Feb 13 11:03:23 UTC 2007


I'm a Myth n00b, running fc6 and a Myth setup based on Jarod's excellent HOWTO.  
Everything is working save lirc.  I've tried both Axel's rpms and a fresh 0.8.1 
install from source, to no avail.  I'm using the ione Libra-Q11 remote and 
receiver, which should be compatible with lirc_mceusb2, but it seems like the 
lirc kernel modules are messing with the USB subsystem in some way.

When I physically plug in the receiver without the kernel modules installed, I 
get the following in /var/logs/messages:

Feb 13 05:01:50 hostname kernel: usb 1-2.1: reset full speed USB device using 
uhci_hcd and address 17
Feb 13 05:01:50 hostname kernel: usb 1-2.1.4: new full speed USB device using 
uhci_hcd and address 80
Feb 13 05:01:51 hostname kernel: usb 1-2.1.4: configuration #1 chosen from 1 
choice

Looks fine.  However, after installing lirc, plugging in the receiver yields the 
following:

Feb 13 05:08:19 hostname kernel: usb 1-2.1.4: new full speed USB device using 
uhci_hcd and address 82
Feb 13 05:08:20 hostname kernel: usb 1-2.1.4: configuration #1 chosen from 1 
choice
Feb 13 05:08:20 hostname kernel: lirc_dev: IR Remote Control driver registered, at 
major 61
Feb 13 05:08:20 hostname kernel:
Feb 13 05:08:20 hostname kernel: lirc_mceusb2: Philips eHome USB IR Transciever 
and Microsoft MCE 2005 Remote Control driver for LIRC $Revision: 1.21 $
Feb 13 05:08:20 hostname kernel: lirc_mceusb2: Daniel Melander <lirc at rajidae.se>, 
Martin Blatter <martin_a_blatter at yahoo.com>
Feb 13 05:08:21 hostname kernel: usb 1-2.1.4: reset full speed USB device using 
uhci_hcd and address 82
Feb 13 05:08:28 hostname kernel: usb 1-2.1.4: failed to restore interface 0 
altsetting 0 (error=-110)
Feb 13 05:08:28 hostname kernel: lirc_dev: lirc_register_plugin: sample_rate: 0
Feb 13 05:08:28 hostname kernel: lirc_mceusb2[82]:  on usb1:82
Feb 13 05:08:28 hostname kernel: usb 1-2.1.4: USB disconnect, address 82
Feb 13 05:08:28 hostname kernel: lirc_mceusb2[82]: usb remote disconnected
Feb 13 05:08:28 hostname kernel: usb 1-2.1.4: new full speed USB device using 
uhci_hcd and address 83
Feb 13 05:08:28 hostname kernel: usb 1-2.1.4: configuration #1 chosen from 1 
choice
Feb 13 05:08:28 hostname kernel: usb 1-2.1.4: reset full speed USB device using 
uhci_hcd and address 83
Feb 13 05:08:33 hostname kernel: usb 1-2.1.4: failed to restore interface 0 
altsetting 0 (error=-110)
Feb 13 05:08:33 hostname kernel: lirc_dev: lirc_register_plugin: sample_rate: 0
Feb 13 05:08:33 hostname kernel: lirc_mceusb2[83]:  on usb1:83
Feb 13 05:08:33 hostname kernel: usb 1-2.1.4: USB disconnect, address 83

This loop continues ad infinitum, with the device being recognized, then 4-7 
seconds later spontaneously being disconnected and reconnected.  lircd seems to 
run happily enough, but irw exits immediately after starting and takes down 
lircd with it.  For the record, the behavior is the same when plugging directly 
into the computer, rather than the hub shown here.

Has anyone seen this behavior?  I'm looking forward to solving this last piece 
of the Myth puzzle, so any help would be greatly appreciated.

--------------------------------------------------------------------------------

my /etc/modprobe.conf:

alias eth0 8139too
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
options snd-emu10k1 index=0
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; 
/sbin/modprobe -r --ignore-remove snd-emu10k1
# nvidia kernel module
alias char-major-195 nvidia-1_0-9746
alias nvidia nvidia-1_0-9746
# ivtv module setup
alias char-major-81 videodev
alias char-major-81-0 ivtv
# lirc module setup
alias char-major-61 lirc_mceusb2

some other debugging info:

[root at hostname ~]# ll /dev/li*
crw-rw-rw- 1 root root 61, 0 Feb 13 05:06 /dev/lirc
srw-rw-rw- 1 root root     0 Feb 13 05:23 /dev/lircd
prw-r--r-- 1 root root     0 Feb 13 04:05 /dev/lircm

[root at hostname ~]# lsmod | grep irc
lirc_mceusb2           17391  1
lirc_dev               19476  1 lirc_mceusb2


More information about the mythtv-users mailing list