[mythtv-users] problems with diskless setup

Rich West Rich.West at wesmo.com
Mon Feb 12 22:49:18 UTC 2007

Rich West wrote:
> Richard Scott wrote:
>>> A few hours of work, and I'm making some progress, but I've reached a
>>> point that where I'm a bit lost.  I'm setting up a diskless boot
>>> environment for fc6 based on the system-config-netboot-0.1.34-1_FC3.  It
>>> seems to be working in a sane mannor -- the logic of the disklessrc file
>>> is to mount the readonly root fs then mount rw the snapshot fs. It then
>>> does a mount -bind to map the files off the snapshot fs over the ro
>>> files from the main mount.  However, after the mount -bind operation,
>>> these files are still Read-only.  I tried going through the same steps
>>> locally, and it works as expected - I can't write to the files that are
>>> ro, but after a mount -bind I can.  This doesn't seem to be he case with
>>> the diskless installation.  Any thoughts?  Any way to get a shell from
>>> that disklessrc file so i can poke around?
>> I've had this problem as well - fc5 also fails with kernels 2.6.18 and
>> above. I seem to remember reading somewhere that the kernel option
>> CONFIG_NFS_FSCACHE is responsible - I keep meaning to try recompiling my
>> fc5 kernel without this option to see if it works, but haven't got round
>> to it yet.
> I hate to be one of those "I'm having this problem, too" people, but I 
> am experiencing the same problem. :(
> I was finally able to get the system to nfsboot (hooray), but I have a 
> bunch of errors when things try to start up complaining that I'm finding 
> that the filesystem remains read-only and, hence, won't start up X.. or 
> much of anything, for that matter.  On the other hand, the system is 
> nice and quiet. ;)
> I tried "mount -o remount,rw /", and, shortly afterward, my main server, 
> everything freaked out causing it to hang.  Not sure if it was related, 
> but that made my heart skip a few beats..
> Of course, I am stuck in the middle where I had used 2.6.20 as the base 
> kernel to rebuild, but, of course, nvidia and lirc related RPMs are not 
> easily available for this kernel under FC5.  I think I will just 
> download 2.6.18 and work with that..

I backed down to the default FC5 kernel (2.6.18-2257) and managed to get 
it to boot with the same issues.

A-ha!  I remounted /var/log in read/write mode, and, viola!  I managed 
to get somehwere. :)  I brought the system down to init 3, ran "mount -o 
remount,rw /var/log", and brought it back to init 5 and the FE came up 
(Gnome barfed about a few issues regarding power management, though).

I'm not sure why /var/log/ isn't being mounted read-write


More information about the mythtv-users mailing list