[mythtv-users] sa3250HD Channel Change

Eric Smith erictsmith at gmail.com
Mon Feb 12 00:40:27 UTC 2007

I recently updated my backend to FC6 and moved my old database and
recordings directory back onto the machine.  The whole upgrade went
amazingly smooth.  At the same time, i received an "upgrade" to my
sa3250HD cable box from Time Warner to their "Time Warner Navigator"
One of those two things seems to have broken the channel change over
firewire using both the internal mythtv support and sa3250ch.  The STB
is not responding at all.  I remember when i originally set up the box
i had some issues with it changing to the incorrect channel... just to
be clear, its not doing this... the STB is simply not doing anything.
I don't remember exactly what the edits i made to sa3250ch.c to make
it work that time.  But i believe it was essentially what the new -s
switch provides.
Verbose output from sa3250ch shows that it is finding the box and
thinks it is changing the channel.  I have tried using the individual
digits method and the -s switch.  Both with the same result.
Has anyone else received this upgrade from TWC?  Any thoughts?

 ./sa3250ch -v 240
node 0: vendor_id = 0x000011e6 model_id = 0x00000be0
AV/C Command: 240 = cmd0=0x00487ce7 cmd2=0x04303432 cmd3=0xff000000
AV/C Command: 240 = cmd0=0x00487c67 cmd2=0x04323430 cmd3=0xff000000

More information about the mythtv-users mailing list