[mythtv-users] firewire: test-mpeg OK, but can't record in myth

Chris Weiland hobbiticus at gmail.com
Wed Feb 7 18:53:23 UTC 2007


This sounds a lot like my problem.  I CAN record the ATSC channels, but some
time after I start watching live tv over the firewire, the audio turns into
a high pitched whine, and when I tune off of the channel (changing the
channel, stop watching livetv, or killing the frontend or backend
processes), my computer hard locks and I have to reboot.  Even with kernel
2.6.20 and a mythtv svn checkout from mid january, the problems still occur.

The weird thing is that I havn't gotten this lockup when just recording.
And after I reboot, I can watch the parts that had the high pitched whine
just fine - no audio corruption.  It's when I'm recording AND watching -
either live or watching the recording as it's being recorded.

And by the way, every time I reboot, I have to set the permissions on
/dev/raw1394 then run the firewire primer script.  (Both of which I've
recently fixed so I do not have to do this manually)


On 2/7/07, Steven Adeff <adeffs.mythtv at gmail.com> wrote:
>
> On 2/6/07, Stephen Sassman <sassman1 at gmail.com> wrote:
> > I had firewire working quite well until yesterday. I was playing
> > around with trying to get some of the hi-def channels to work, when
> > things went bad. I was able to record from all of the NTSC channels,
> > and also FOX and ABC ATSC channels. I was actually doing this through
> > ssh and mythweb. When I tried to record from NBC, mythweb indicated an
> > error (B where the number of MB should be). I have never been able to
> > record NBC or CBS ATSC channels, but I thought I would give it a try
> > since things were working so well.
> >
> > Big mistake! When I got home X was locked up. After rebooting,
> > firewire no longer works through myth. I can record with test-mpeg
> > just fine. I am using 0.20. Anyone know if the firewire code is
> > improved in SVN trunk? I have found it to be somewhat unreliable.
> > Don't get me wrong: Mythtv is awesome and I REALLY appreciate all of
> > the work that the developers have done. Just would like to figure out
> > what the deal is with my firewire.
>
> have you tried the firewire_tester app in the contrib folder?
>
> --
> Steve
> Before you ask, read the FAQ!
> http://www.mythtv.org/wiki/index.php/Frequently_Asked_Questions
> then search the Wiki, and this list,
> http://www.gossamer-threads.com/lists/mythtv/
> Mailinglist etiquette -
> http://www.mythtv.org/wiki/index.php/Mailing_List_etiquette
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070207/bdf8da4d/attachment.htm 


More information about the mythtv-users mailing list