[mythtv-users] Surround Sound AS3/DTS out SPDIF [FIXED!]

Josh TwoOneSix at thatclothingco.com
Wed Feb 7 00:56:44 UTC 2007

Kevin Kuphal wrote:
> Josh wrote:
>> Josh wrote:
>>> Kevin Kuphal wrote:
>>>> Josh wrote:
>>>>> As anyone that's been reading the list recently knows, I have a 
>>>>> Revolution 7.1 that I can get everything to work with except for AC3 or 
>>>>> DTS pass through... it just doesn't work for me on Fedora Core 6 (or 
>>>>> Fedora Core 5). I have all but given up on this card and want to buy one 
>>>>> that I know will work.
>>>>> Can people that have AC3 and/or DTS pass through working over S/PDIF 
>>>>> (Coax or Optical) please let me know what distro and sound card your using?
>>>> Get a Turtle Beach Riviera.  Works out of the box with Fedora.  No 
>>>> .asoundrc.  Just enable the IEC958 in alsa-mixer, set Myth to 
>>>> passthrough and ALSA:default and go.
>>>> Kevin
>>>> _______________________________________________
>>>> mythtv-users mailing list
>>>> mythtv-users at mythtv.org
>>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>>> See... That's the first card that I bought and when I brought it home 
>>> and plugged it up, it worked for about 30 minutes, then it stopped for 
>>> no apparent reason (but apparently there WAS a reason it stopped and I 
>>> couldn't figure out what it was). I have an idea... I'm going to remove 
>>> (backup) my configs, shutdown my front end, swap out the cards and try 
>>> this simple solution you suggest... I'll post back shortly with the results.
>> It's been an hour and I haven't even heard a peep from this card... 
>> maybe I should check into a rubber room for a couple of days and see if 
>> that helps any.
> Put it into a windows box and see if your card isn't dead.
> Kevin
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Kevin, I would love to give you credit for that solution if I had only 
checked my e-mail 20 hours ago... Here is what transpired this PM (this 
is a cut and paste of what I posted to the Alsa-User mailing list:
OK, so the problem is fixed and as far as I'm concerned it was my fault 
for not catching this issue sooner. I don't know about the M-Audio 
Revolution 5.1 or 7.1 issues I was having, but the reason I tried them 
in the first place was because my 1st option wasn't working. So, I 
revisited my 1st option (Turtle Beach Riviera) and, like I had posted 
previously on this list, it worked for about 30 minutes and then 
mysteriously stopped working. Well, I moved on to the M-Audio card after 
2 days of trying to get that Turtle Beach card to work... the M-Audio 
card caused me all kinds of grief with AC3 and I never could get it 
working... Here is the output from mplayer that made me finally give up 
on the M-Audio card (remind you I'm on Fedora Core 6 - FC6).
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
[AO_ALSA] Format s16le is not supported by hardware, trying default.
[AO_ALSA] Unable to set format: Invalid argument
Could not open/initialize audio device -> no sound.
Audio: no sound
Starting playback...
I know the Revolution only supports S32LE but it was the last straw and 
I decided to pull the card and go back to my Turtle Beach since I had 3 
or 4 different people tell me it works fine OTB (and it worked OTB for 
me for a short time)... Nothing too much was going for me with this card 
either... Well, after 2 more hours of messing with the Turtle Beach card 
and finally getting mplayer to output this:
Forced audio codec: hwac3
Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
No accelerated IMDCT transform found
hwac3: switched to AC3, 192000 bps, 48000 Hz
AUDIO: 48000 Hz, 2 ch, ac3, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [hwac3] afm: hwac3 (AC3 through S/PDIF)
AO: [alsa] 48000Hz 2ch ac3 (1 bytes per sample)
Starting playback...
I knew at that point ALSA could see my card and the S/PDIF output and it 
was obviously outputting AC3 data to my card... so I whipped out the 
manual for my Sony digital receiver... it says the same thing it did the 
day I brought it home; that it supports all digital modes and will 
auto-select the input source... so I take a quick gander at the 
receivers LCD panel and notice that the "OPT" (Optical) light is not 
lit, this means that it's not getting a signal at all from the device 
(my computer) let me say that the receiver light lights up upon 
connection with a digital device, it doesn't even have to be accepting 
data; like a power cord on a computer monitor lights up a small light to 
let you know it's plugged in but not powered on... any who, seeing this 
I yank the Matix optical cable from the setup, power down my box, yank 
the Riviera take them both back to Fry's and swap them out with BOTH new 
items, come home, plug them up and BAM, every thing's working exactly 
like it should! 5 days of wasted effort because of a hardware failure!!! 
I guess I learned more about ALSA, mplayer, MythTV, digital audio 
formats, and supported Linux hardware then I would have had the card 
"just worked" so I can't be too upset with the experience.

The lesson learned here is to never forget that when you get stuck and 
all else fails, go back to your A+ certification study and remember that 
if an issue is just plain "weird and unexplainable" look at the 
hardware. Thanks Lee (on the ALSA list) and John (on this list) for 
trying to help. As for the Revolution 7.1 ($99) I couldn't get it to 
work with Dolby Digital 5.1 out the RCA SPDIF, but the Riviera ($34) 
works with everything I have, mp3, ac3, dts, SPDIF out of the Optical 
port... I'm just glad this is over and everything is working as I want now.

Previously,  I said "at this point I can't recommend the Turtle Beach 
Riviera to anyone on FC6" now, I can say "If your on FC6, buy the damn 
card! It's the best bang for your buck... at $34 you can't pass up the 
quality." As I said before, had the hardware not failed, this would have 
been working in < 5 minutes, but since the hardware problems, it was 5 
days... <sigh> I'm sure everyone will be glad that I won't be posting 
about this issue anymore. :-)

P.S. I never did figure out if it was the optical cable or the sound 
card and frankly, I don't care which one it was because it's working now.
~~My MythTV settings~~
Audio Output: ALSA:default
Pass-through: ALSA:spdif
Music Audio: default


More information about the mythtv-users mailing list