[mythtv-users] Performance issues with version 0.21_pre15014

Håkon Alstadheim hakon at alstadheim.priv.no
Sat Dec 22 23:00:02 UTC 2007

I'm running myth on gentoo, currently at mythtv 0.21_pre15014, which 
gets pulled from svn. I recently upgraded from  0.20.<something> in 
preparation of working on dvb-t reception issues. I haven't got to that 
yet, because getting up and running with my old analog channels has 
proved challenging.

Myth has frequently been maxing out my cpu, also before the upgrade. 
Cpuinfo says I have a "Intel(R) Pentium(R) 4 CPU 2.00GHz", with ~70% 
going to recording to MPEG4 (simple Haupaugue card) and ~30% to 
playback. Very occasionally I had lost video frames before the upgrade. 
Totally watchable and better total user-experience than xdtv.

After the upgrade both the backend and the frontend occasionaly want 
 >80% of the cpu.  As I have a single core, this means something has to 
give. Now, the interesting thing is that just recording (without 
watching) in myth, and playing back the recording in vlc AS IT IS BEING 
RECORDED, works ok, with vlc taking 20-40% and mythbackend the rest (a 
tiny bit is going to X and other things like mysql, same as when running 
myth FE/BE). Some dropped video-frames, but the sound is rock solid, no 
glitches. Myth on the other hand, when anything appears, will frequently 
skip entire sections of sound and video, making it impossible to 
understand what is going.

This thing with extreme cpu use does not happen always. The sure way to 
get nothing on the screen is to start watching a channel with a noisy 
signal (hard to compress), although even there I got OK performance once 
quite recently. What happened was that when the first frame finally 
appeared (after ~30 seconds), and I tried changing channels and then 
hitting escape, the keyboard became totally unresponsive, and the video 
started running quite smoothly.

This is with the "CPU+" playback profile. "CPU-" invariably gives no 
output (screen and sound) or just some mpeg artefacts (colored squares 
on the screen or something such), never more than one frame (I've tried 
waiting for one hour at least once).

I've tried recompiling ffmpeg and mpeg libraries, unmasking testing 
versions, but that does not help.  Still, recording with myth and 
watching AT THE SAME TIME in vlc, is just dandy. What should I try? The 
options I see right now is switching to xdtv (no recordings), or 
downgrading. Spending two hours hacking the database to downgrade seems 
very unproductive, but do I have a choice ?

More information about the mythtv-users mailing list