[mythtv-users] WakeOnAlarm still not working

Peter Carlsson maillist.peter at home.se
Thu Dec 13 08:19:55 UTC 2007

nospam312 <nospam312 at gmail.com> wrote:

>> Maybe I wasn't clear enough in my explanation below but step 1-3
>> works. Also, I have verified (as explained below) that step 4
>> writes the content of /proc/acpi/alarm to the nvram but doesn't
>> actually wake it up.

> Are you using/executing the shutdown command anywhere?

> If you are replace with just [sudo] poweroff (no parameters).  If I
> follow the guides and use shutdown it does not work (it writes to
> /proc/acpi/alarm correctly etc) but never starts up.  However if I use
> the poweroff command instead of shutdown it works.

> No idea why and it has had me perplexed for weeks since upgrading to
> [Myth]Ubuntu 7.1 but this solution works for me and seems to have no
> ill effects so far for the little time I have been running it.

In my desperate attempt to solve this problem I am pretty sure I have
tried shutdown with different parameters as well as poweroff.

The other day I tried with a Ubuntu 7.10 LiveCD and it worked! I think
the problem is that in my Debian Etch the kernel version is 2.6.18 and
Ubuntu 7.10 had a newer kernel (2.6.22).

I will install a newer kernel but I want to keep Etch. So I have to
update only the kernel. But that will force me to handle modules for
(ivtv, nvidia etcetera).

Best regards,
Peter Carlsson

More information about the mythtv-users mailing list