[mythtv-users] Working too fast?

Craig Huff huffcs at yahoo.com
Fri Aug 31 18:47:58 UTC 2007

I got data that looks bad in the mythfilldatabase log file after my first attempt with the SchedulesDirect grabber.

Here's what I did:
Created an account at the SchedulesDirect website,
paid with PayPal,
created a lineup to match my old Zap2It one,
logged out of Schedulesdirect,
logged back in to make sure I had the username and password straight,
logged out again,
shutdown mythbackend with "#service mythbackend stop",
ran mysqldump to backup the database,
ran mythtv-setup per the instructions,
    NOTE: This was a little confusing because I expected to see the Zap2It grabber still listed so I wasn't sure I was getting the right grabber until I checked the whole list.  Then when I tried to "Retrieve Lineups", I got no lineup data.  I had to get out of the Video Sources window and re-enter it before I saw a lineup name.  This was another point of confusion, so I went back to SchedulesDirect to see if I could match it up with a name of the lineup I just created, but I couldn't find a name for the lineup in the web page, so maybe that is my problem ;-(
exited mythtv-setup completely,
    NOTE 2: According to the directions in the HOWTO, paragraph 24.3 I was supposed to then run mythfilldatabase, which I did, but it wants to talk to the backend when it's done.  Maybe mythbackend should have been started before running mythfilldatabase?  In any case, it waited for 120 seconds before trying again, (I think I must have set that delay somewhere in the settings, myself) and I was able to open another terminal window and fire up mythbackend before mythfilldatabase squawked anymore.
and ran mythfilldatabase.

In the mythfilldatabase output, I got the following lines:

2007-08-31 13:27:58.435 Retrieving datadirect data.
2007-08-31 13:27:58.435 Grabbing data for Fri Aug 31 2007 offset 1
2007-08-31 13:27:58.435 From Sat Sep 1 05:00:00 2007 to Sun Sep 2 05:00:00 2007 (UTC)
2007-08-31 13:27:58.435 Grabbing listing data
--13:27:58--  http://datadirect.webservices.zap2it.com/tvlistings/xtvdService
Resolving datadirect.webservices.zap2it.com...
Connecting to datadirect.webservices.zap2it.com||:80... connected.
HTTP request sent, awaiting response... 401 Unauthorized
Reusing existing connection to datadirect.webservices.zap2it.com:80.
HTTP request sent, awaiting response... 401 Unauthorized
Authorization failed.

I wasn't sure if I was just too fast for SchedulesDirect and they haven't
activated my account yet, possibly still processing the PayPal
payment or if I botched something because the URLs have ".zap2it.com" in them?

Can anyone shed some light on this?


Got a little couch potato? 
Check out fun summer activities for kids.

More information about the mythtv-users mailing list