[mythtv-users] No firewire output after upgrade

Raphael rpooser at gmail.com
Tue Aug 28 02:27:43 UTC 2007

Tom Greer wrote:
> I have a home system comprising of four MythTV frontend/backend combo 
> boxes.  Three are attached to DCT-6xxx boxes.  The fourth uses an 
> HDHomeRun as input.  All four boxes are similarly configured running 
> Ubuntu 7.04.
> Last weekend, in an effort to prepare for a transition to Schedules 
> Direct, I upgraded all of these boxes to the latest SVN version.  At the 
> same time, I also upgraded Ubuntu to the latest packages (including the 
> kernel to 2.6.20-16).
> Everything went fine. 
> Except now, all of the systems attached to DCT boxes fail to receive 
> video.  In MythTV, I cannot tune any channels - and all attempts to 
> record programs fail. 
> When I run plugreport, everything looks normal.  But firewire_tester 
> reports failure both as a broadcast connection or as a point-to-point 
> connection.
> I have tried rebooting and loading the old version of the kernel.  The 
> results are the same.
> Before the upgrade, all of these boxes worked fine.  Now they all fail.  
> Since, I was stupid enough to upgrade the kernel and MythTV at the same 
> time, I really don't know which caused the problem.
> While it is possible that my cable provider downloaded new software 
> which disabled firewire output at the same time, I think the odds of 
> that are pretty remote.
> I'm looking for some pointers as to how to troubleshoot this.  There are 
> no error messages, just a failure to receive output from the DCT boxes.  
> HELP! 
> Thanks.
> Tom

To me that really sounds like a kernel problem. Couple things to try 
would be:

check test-mpeg2 which comes with the source version of libiec61883 
(http://www.mythtv.org/wiki/index.php/FireWire#Test-mpeg2). I have it 
since I had to compile that lib from source.

And of course you can try rebooting and at the bootloader select your 
previous kernel. Check and see if firewire works with that, and if so 
it's the new kernel, if not, then it could be the new myth version, 
especially if test-mpeg2 works by itself.


More information about the mythtv-users mailing list