[mythtv-users] IVTV driver has stopped responding

Mike LaPlante mike at dividia.net
Wed Aug 22 16:35:20 UTC 2007

scott at tbwifi.ca wrote:
>> Anything in messages in /var/log?  I saw this a lot when I had the
>> infamous DMA timeout issue(s) with the ivtv driver.  Once I got to a
>> version of ivtv that did not have that problem, as well as move my mysql
>> database back to the backend, all of my ivtv issues seem to have
>> disappeared...
>> Brian
> Brian,
> What distro are you using and what version of ivtv did you need to get to
> to resolve your issues?  I am almost to the conclusion that 0.7.4 is a
> waste of time.  It would appear that the associated kernel 2.6.17 has some
> major issues with ivtv that are difficult to overcome.  I'll have to have
> a look at my /var/log file later to see if I'm experiencing what you were.
> Scott
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I ran into these same error messages last week. Strangely enough it was 
only for recordings on my PVR-250, the PVR-150 was working fine. I'm 
running Fedora 7 and it all started after upgrading to 2.6.22. But I had 
some funky yum complications. I think it went something like this. 
(might be forgetting a few steps)
1. I did a yum update to get the new kernel.
2. yum bitched about dependencies for ivtv-kmdl, couldn't find a 
matching package for the 2.6.22
3. some searching on atrpms revealed a video4linux-ivtv-kmdl. I thought 
maybe the package name changed so I installed this and rebooted.
4. Everything seemed okay for a few days(its possible nothing recorded 
from this tuner those days). Then started seeing 0 byte recordings, 
searching the backend logs revealed error messages just like Scott reported.
5. Back to atrpms and I found the ivtv-kmdl package for 2.6.22 so I 
installed this and left video4linux-ivtv-kmdl in place.
6. Everything worked for a few days then more 0 length recordings. I 
know I tested the PVR-250 after this reboot, but only for a few minutes.
7. I have just, a few days ago, removed video4linux-ivtv-kmdl, but I 
still have ivtv-kmdl in place.

Everything has been going good for a few days now. I think all is good 
now. I don't know what the difference in those two packages are. I 
understand that IVTV was recently incorporated into the kernel. Maybe 
that has something to do with it.

As of right now here are the IVTV related packages I have installed, if 
that helps any.
[root at myth ~]# rpm -qa | grep ivtv
[root at myth ~]#


More information about the mythtv-users mailing list