[mythtv-users] DVD VOB Index/Position Issue

Steve MacLaren scram69 at gmail.com
Mon Aug 20 18:48:48 UTC 2007

On 8/18/07, jmk <jmk at foofus.net> wrote:
> Hi,
> I'm having some issues with MythVideo displaying the correct position
> within a "Perfect" (VOB) DVD rip. This issue seems to be present for me
> with both current SVN and -fixes. As an example, the most recent DVD I
> ripped is displayed as 5 seconds long every time I play it. I've also
> had videos display as other incorrect amounts (30 minutes, 1 hour, etc).
> I can jump within the video as long as I'm before the amount displayed.
> The video will play past the point displayed, but jumping no longer
> works. If I transcode the DVD, to say "Excellent" quality, this is not
> an issue.
> Have others encountered this issue? Is there a way to regenerate the
> position data within a VOB?
> Thanks,
> Joe

Well, I would tell you to give mythcommflag --video a try, but I know from
experience that for this situation it does not fix the incorrect time issue.

Then, I'd tell you to try mplayer instead, but in my experience, mplayer
exhibits the same problem when trying to skip forward past the time which
the internal player says is the end of the video.

So it seems to me that there is something fundamentally wrong with the .vob
file when mythDVD rips it from the disk.  Maybe someone knows of an
application that "fixes" .vob files?

Note: if you try to raise an issue with mythDVD import, you will probably
get slapped down...

"It's easy enough to name those who would piss themselves with joy over the
prospect of a One World corporate state, with billions of people begging to
work for their 1,500 calories a day and an xBox chip in their necks."
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070820/cecfb63e/attachment.htm 

More information about the mythtv-users mailing list