[mythtv-users] Device File and X Issue

Nick Morrott knowledgejunkie at gmail.com
Thu Aug 9 02:34:26 UTC 2007

On 09/08/07, Michael Starks <mythtv at michaelstarks.com> wrote:

It's been a while since I've used the FB on my PVR-350, so please bear
with me...

> The first and maybe only problem seems to be that I don't have a proper
> device file.  There is a PVR250 and PVR350 in this machine, but only one
> seems to be recognized, as demonstrated below:
>  [root at moya ~]# ls -l /dev/fb?
> crw------- 1 root root 29, 0 Aug  6 13:53 /dev/fb0
> I tried to create the framebuffer device like so: mknod /dev/fb1 c 29
> 32.  That worked, but it disappeared on reboot.
> I used to have 2 framebuffer devices; fb0 was for the 250 and fb1 was
> for the 350.  You can see where it's looking for the device in
> Xorg.0.log below.  No hardware shuffling has taken place, so I can't
> imagine this should have changed.

I'm quite sure you would not have had a framebuffer device for a
PVR-250. This does not support video out. If you did have another fbx
device it's likely to have been from your video card.

> [root at moya ~]# cat /proc/fb
> 0 cx23415 TV out

This is telling you that /dev/fb0 is the correct device to use for
your PVR-350 output...

Looking in the Xorg.0.log:

> (II) IVTVDEV_TST: driver for framebuffer: PVR-350
> (II) Primary Device is: PCI 01:00:0
> (WW) ivtvdev: No matching Device section for instance (BusID PCI:2:13:0)
> found
> (--) Chipset PVR-350 found

we're still looking for a non-existent /dev/fb1 device

> (EE) open /dev/fb1: No such file or directory
> (EE) Screen 0 deleted because of no matching config section.
> (II) UnloadModule: "ivtvdev"
> (EE) Device(s) detected, but none match those in the config file.
> Fatal server error:
> no screens found

because in your Xorg.conf file:

> Section "Device"
>         Identifier  "Hauppauge PVR 350 iTVC15 Framebuffer"
>         Driver      "ivtvdev"
>         ### change fb1 to whatever your card grabbed
>         Option      "fbdev" "/dev/fb1"
>         Option      "ivtv" "/dev/fb1"

you are still referencing the missing /dev/fb1 device.

Have you tried updating your Xorg.conf file to point to /dev/fb0 instead?

No hardware shifting may have occured, but you have changed distro and
your video card driver may not be creating a dev/fbx entry any more.
PCI IDs have also been known to change around.


MythTV Official wiki:
MythTV users list archive:

"An investment in knowledge always pays the best interest." - Benjamin Franklin

More information about the mythtv-users mailing list