[mythtv-users] Device File and X Issue

Sam Varshavchik mrsam at courier-mta.com
Thu Aug 9 02:13:34 UTC 2007

Michael Starks writes:

> I posted this to ivtv-users a couple of days ago but didn't get any
> useful feedback yet.  Sorry for the cross-post, but I have a system down
> issue and the WAF is rapidly declining!
> -----------------------------------------------------------------------------------------
> I recently switched from Fedora Core 4 to Centos 5 (a clean install, of
> course).  I didn't have an issue with Fedora but I can't seem to get X
> to display on the TV using the PVR350 out.
> The first and maybe only problem seems to be that I don't have a proper
> device file.  There is a PVR250 and PVR350 in this machine, but only one
> seems to be recognized, as demonstrated below:
>  [root at moya ~]# ls -l /dev/fb?
> crw------- 1 root root 29, 0 Aug  6 13:53 /dev/fb0
> I tried to create the framebuffer device like so: mknod /dev/fb1 c 29
> 32.  That worked, but it disappeared on reboot.

Do you have the saa7127.ko kernel module, and is it loaded? There were some 
issues with some Fedora kernels -- and it might've made its way to CentOS 

With some kernels, I recall that saa7127.ko module wasn't getting 
automatically loaded, for some reason.  Manually modprobe it before loading 

With other kernels, saa7127.ko wasn't even built, for some reason. In those 
cases, you'd have to grab video4linux, build just the saa7127.ko module, and 
install it.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20070808/55638ba1/attachment.pgp 

More information about the mythtv-users mailing list