[mythtv-users] Ongoing Fedora YUM Dependency Problems

jack snodgrass mrlinuxgroups at gmail.com
Fri Sep 29 00:50:57 UTC 2006

On 9/28/06, Andrew Davis <andrew at nccomp.com> wrote:
> Funny, just last weekend I did a clean install of FC5 and installed Myth
> and other than some issues with my remote (which are resolved now), its
> 99% working and the underlying FC5 is running w/o issue. Perhaps your
> ranting is about your own installation choices. :)
> Tom Greer wrote:
> > This email is simply a rant...  but I need to express my frustration,
> > so I'm begging forgiveness in advance.
> >
> > I've been using MythTV for over a year now.  I originally tried to
> > make it work with SuSE (wasted lots of time there), until I found
> > Jarod Wilson's wonderful HOW-TO for installing Myth on Fedora Core 4.
> > (Thank you, Jarod!)  I switched to Fedora and got MythTV installed and
> > working on 2 machines.
> >
> > But over the year, I continually experienced problems when updating or
> > upgrading via yum.  Over and over again, yum refused to do anything
> > because of dependency problems.  Each time, I had to invest time and
> > effort to work around the problem.
> >
> > When I was confronted with the problem again this week, I decided to
> > upgrade to Fedora Core 5.  So I downloaded the DVD ISO, verified the
> > DVD was good and upgraded the master backend.  After the upgrade, the
> > system couldn't launch the X server.  So I tried to run "yum
> > upgrade".  It refused due to a conflict over the boot image.
> >
> > So I copied all my recordings to another box and dumped a backup of
> > mythconverg - and did a clean install of  Fedora Core 5.  Immediately
> > after first boot, I tried "yum upgrade".  Same problem.
> >
> > I'm giving up on Fedora.  Hello Ubuntu...
> > ------------------------------------------------------------------------
> >

the only issue I have with Fedora and Yum out of the box is the
'mirror' system that they use. Unless you specifically go into the
yum.repos.d files and specify a close mirror, you may be trying to
load packages from half-way across the planet. It's totally random.
If you get a 'bad' mirror, you may have issues updating / upgradeing.
I know which mirrors are close to my geographic location so I
put those into my yum config files before I ever do a yum upgrade.


More information about the mythtv-users mailing list