[mythtv-users] Protocol version mismatch

Paul Bender pebender at san.rr.com
Wed Sep 27 06:41:41 UTC 2006

Nowhere wrote:

> Hey everyone,
> I just built a new dedicated remote frontend and installed following 
> Jarod's guide. I built the backend server a short while ago so now I am 
> getting the error message:
> Protocol version mismatch (frontend=31,backend=30)
> when I try to Watch Recordings.
> I tried stopping the backend, then yum -y install mythtv-suite to 
> upgrade the master backend machine per Jarod's guide. It says something 
> about updating but the remote frontend still says the same error. 
> At the same time built the backend, I installed a frontend on a VMWare 
> Workstation virtual machine on my windows box (works great btw). So I 
> decided to try upgrading it and see if I can force the mismatch on it. 
> So I tried
> yum -y update mythtv-suite,
> yum -y upgrade mythtv-suite,
> yum -y update mythtv
> and none of that forces the mismatch.
> It should be obvious by now I don't really understand how yum is working 
> so the question is:
> How do I get the backend to network protocol version 31?
> Thanks!
> Eric

In the past day or so, ATrpms picked up a fix from the 20 fixes branch 
that bumps the protocol version. If you do an 'rpm -qa | grep myth', are 
all the version *-139, or are some older?

More information about the mythtv-users mailing list