[mythtv-users] opengl video sync crashes

Preston Crow pc-mythtv06c at crowcastle.net
Tue Sep 26 13:00:59 UTC 2006

On Mon, 2006-09-25 at 20:15 -0700, Anduin Withers wrote:
> > I notice in the logs that it first tries to use nVidiaVideoSync, but the
> > VBlank ioctl does not work, indicating that it might not be supported in
> > the driver.  I'm running 8774 with X 7.1 (Gentoo, if it matters).
> Yes, many people are confused about what sync mechanism is chosen and why.
> It is a list, it is checked linearly, the first to work is used. Enabling
> OpenGL simply allows it to check for it in that list. The current list goes:
> nVidia vblank, DRM, OpenGL (if enabled), RTC, usleep.

Yup, I saw that in the source.  Do you know if the nVidia vblank ioctl
has been removed in newer drivers in favor of using OpenGL (it would
make sense to tell people to use a standard method instead of a
proprietary one)?

> > Could this be related to ticket 2383?  I noticed that the patch is
> > applied in the Gentoo ebuild.  I tried downgrading Mesa, and that didn't
> > help.  I tried applying the patch, and that didn't help, either.
> The only thing 2383 does is load the sync functions dynamically rather than
> counting on them being linkable. The best you could hope from 2383 is that
> it would fail faster (though you can do that by just disabling OpenGL vsync
> in the settings). I'd suspect the GL portion of your driver install.

I'll try reinstalling the nVidia drivers again, but I'm not optimistic.
Has anyone else had this issue?

More information about the mythtv-users mailing list