[mythtv-users] opengl video sync crashes

Anduin Withers awithers at anduin.com
Tue Sep 26 03:15:57 UTC 2006

> I notice in the logs that it first tries to use nVidiaVideoSync, but the
> VBlank ioctl does not work, indicating that it might not be supported in
> the driver.  I'm running 8774 with X 7.1 (Gentoo, if it matters).

Yes, many people are confused about what sync mechanism is chosen and why.
It is a list, it is checked linearly, the first to work is used. Enabling
OpenGL simply allows it to check for it in that list. The current list goes:
nVidia vblank, DRM, OpenGL (if enabled), RTC, usleep.

> Could this be related to ticket 2383?  I noticed that the patch is
> applied in the Gentoo ebuild.  I tried downgrading Mesa, and that didn't
> help.  I tried applying the patch, and that didn't help, either.

The only thing 2383 does is load the sync functions dynamically rather than
counting on them being linkable. The best you could hope from 2383 is that
it would fail faster (though you can do that by just disabling OpenGL vsync
in the settings). I'd suspect the GL portion of your diriver install.

Gentoo doesn't have 2383, is has some Cardoe version of what I put in 2383
(yes, I am guilty of gratuitous template use, but random rewrites with no
list of errors isn't as useful as it could be, knowing why would boost my
confidence in actually applying it).

Anduin Withers

More information about the mythtv-users mailing list