[mythtv-users] nfs truncates mythvideo files

Jason S. Preston acee2bee at gmail.com
Sat Sep 23 22:39:05 UTC 2006

to you,

which version of nfs are you running.  i personally had a problem  
when using an older version, i believe nfs v2, as it limited file  
size to i want to say 2 gb or maybe it was just a gig.  however when  
running nfs v3, that limit was raised significantly, to a point that  
would most likely be unimportant right now.  and even larger in v4,  
think thats experimental now though.

what i'm saying is that if you are using nfs 2, then it will only  
allow smaller file sizes to be written/read.  so it would essentially  
take your larger files and quit writing them at that limit.  i think  
at least.  my issue was when i was recording live tv to an nfs mount,  
it would stop a live show after writing a file that was at said  
limit.  personally running gentoo, and it was an option in the kernel  
setup to enable the various nfs versions.  simply changed to the  
newer version, and i could do all i wanted with giant files.

hope that helps a little bit.
j preston

On Sep 23, 2006, at 5:49 PM, Matthew K. Lee wrote:

> To all,
> I'm having an issue with NFS truncating my files.  I've got about  
> 124 GB worth of video on my source system.  I wanted to watch that  
> through MythVideo on my destination system.
> So, I tried to do an NFS mount - and - I thought it was working.  I  
> could see the directory listing which lists all of the files and  
> all of the right file sizes.  However, when I tried to play those  
> videos, the videos would get truncated after a couple of minutes.   
> Some (the .iso files) wouldn't even load.  Others (.nuv files)  
> would play a few minutes and then exit.
> So then I thought that I would simply copy the files over nfs.  I  
> did, but I had an interesting result.  Only 40 GB of the 124 GB  
> actually transferred.  All the files were listed, but doing things  
> like du -h --max-depth=1 /video/dvd or df -h reported 40 GB worth  
> of data.  On the source those same commands verified that there was  
> 124 GB of stuff to copy over.
> Now I'm totally confused.  Is NFS limited to size of files that it  
> can transfer or did I do something wrong?  Here's my system setup.   
> Thanks in advance!
> Source System:
> --------------------------------------------------------
> Fedora Core 4, reiserfs for the video file system, ext3 for /
> [source]#yum list installed | grep nfs
> nfs-utils.i386                                      
> 1.0.7-12.FC4          installed
> system-config-nfs.noarch                 1.3.11-0.fc4.2          
> installed
> [source]#cat /etc/exports
> /video,root_squash,no_subtree_check)
> /video,root_squash,no_subtree_check)
> /video,root_squash,no_subtree_check)
> Destination System:
> --------------------------------------------------------
> Gentoo 2006.1, reiserfs for the video file system, ext3 for /
> using basic nfs mount commands
> Thanks again,
> Matt
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060923/7066b517/attachment.htm 

More information about the mythtv-users mailing list