[mythtv-users] nfs truncates mythvideo files

Matthew K. Lee fratlee at gmail.com
Sat Sep 23 21:49:31 UTC 2006

To all,

I'm having an issue with NFS truncating my files.  I've got about 124 GB
worth of video on my source system.  I wanted to watch that through
MythVideo on my destination system.

So, I tried to do an NFS mount - and - I thought it was working.  I could
see the directory listing which lists all of the files and all of the right
file sizes.  However, when I tried to play those videos, the videos would
get truncated after a couple of minutes.  Some (the .iso files) wouldn't
even load.  Others (.nuv files) would play a few minutes and then exit.

So then I thought that I would simply copy the files over nfs.  I did, but I
had an interesting result.  Only 40 GB of the 124 GB actually transferred.
All the files were listed, but doing things like du -h --max-depth=1
/video/dvd or df -h reported 40 GB worth of data.  On the source those same
commands verified that there was 124 GB of stuff to copy over.

Now I'm totally confused.  Is NFS limited to size of files that it can
transfer or did I do something wrong?  Here's my system setup.  Thanks in

Source System:
Fedora Core 4, reiserfs for the video file system, ext3 for /

[source]#yum list installed | grep nfs
nfs-utils.i386                                     1.0.7-12.FC4
system-config-nfs.noarch                 1.3.11-0.fc4.2         installed

[source]#cat /etc/exports

Destination System:
Gentoo 2006.1, reiserfs for the video file system, ext3 for /
using basic nfs mount commands

Thanks again,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060923/24703627/attachment.htm 

More information about the mythtv-users mailing list