[mythtv-users] AC3 Passthru doesn't work on Nforce4 ALC850

ubulid00 ubulid00 at fastmail.fm
Sat Sep 16 19:07:08 UTC 2006

Using a Nforce4 Realtek CK804 sound I've been able to get 2 channel SPDIF
outputs working great in mplayer/xine/mythv etc. However, enabling the AC3
passthru of surround sound gives no sound in any of the utilities. 

I've removed the /etc/asound.conf file, enabled 'IEC958' and reduced 'IEC958
Playback AC97-SPSA' in alsamixer.

I'm getting so desperate that I even installed windows on an old harddrive
to debug this, with the result that PowerDVD worked correctly, and VLC
(windows) sort of worked, giving CD skipping-like audio, but the receiver
still at least detected a digital stream. Thus I believe the hardware is OK. 
I had a post on gentoo forums for a few weeks with some info:

There is no sound output when using the linux players (xine,mplayer,myth). 
My Aiwa receiver does not detect a dolby stream (but the liba52 downmixed
SPDIF stream is always ok).  The motherboard is a MSI Neo4 Platinium, and a
Aiwa CK-NDS8 receiver.

Can anyone offer some things to try to get Dolby Digital passthru working on
View this message in context: http://www.nabble.com/AC3-Passthru-doesn%27t-work-on-Nforce4-ALC850-tf2283328.html#a6342925
Sent from the mythtv-users forum at Nabble.com.

More information about the mythtv-users mailing list