[mythtv-users] Anyone using two HD cableboxes with firewire

Yeechang Lee ylee at pobox.com
Mon Sep 11 14:05:05 UTC 2006

Allan Wilson <allanwilson at gmail.com> says:
> I just received my second SA3250HD cable box from Charter and
> plugged directly from the second cable box to an additional firewire
> port, not daisy chaining. Test-mpeg2 works great and I can get video
> from both and Myth sees both ports no problem. The only problem I am
> having is the channel change program only seems to work with my new
> box and now when I am on my old cable box it changes the channel on
> my new box.

I use two Motorola 6200s. Unlike 6200ch.c, sa3250ch.c--at least in the
0.19-fixes release--doesn't seem to have an option for specifying the
node. A few suggestions:

* Do you need to use sa3250ch.c to change channels? If you don't
  specify a channel changing utility in mythtv-setup, can mythbackend
  handle the changing on its own? (I use 6200ch.c only because it may
  be slightly more reliable than mythbackend doing it itself, but am
  not sure I can prove this.)
* You might have to manually hardwire the two boxes' node numbers into
  two different copies of the utility. (If you don't know how, I hope
  someone else can step up.) Call them sa3250ch-1.c and sa3250ch-3.c,
  then tell mythtv-setup to invoke each.
* 0.20 might have fixed this; presumably we'll see soon.

Yeechang Lee <ylee at pobox.com> | +1 650 776 7763 | San Francisco CA US

More information about the mythtv-users mailing list