[mythtv-users] mytharchivehelper fails to get thumbnails

Paul Harrison mythtv at dsl.pipex.com
Sat Sep 2 13:18:35 UTC 2006

John Drescher wrote:
>> OK its possible I broke something in mythreplex.  I would have thought
>> if anything  got broke it would be the audio, I didn't touch the video
>> stream at all!
>> Is this also happening on other files as well?
>> Do you have a file you know  used to work before and does it now fail?
>> You could try removing the --fix_sync option from the mythreplex command
>> line (lines ~ 1319 and 1335) in the mythburn.py script so it should run
>> mythreplex as it was before I fixed it :-)
> Ok, I did that but the problem still is there.
>  tail /tmp/logs/mythburn.log
> Extracting thumbnail image from /tmp/work/1/stream.mv2 at position 0
> Destination file /tmp/work/1/thumbnail.jpg
> 2006-09-02 00:39:42.073 Opening /tmp/work/1/stream.mv2
> 2006-09-02 00:39:54.153 Couldn't get stream info, error #-1
> ************************************************************
> ERROR: Failed while running mytharchivehelper to get thumbnails.
> Result: 256, Command was mytharchivehelper -t
> "/tmp/work/1/stream.mv2" '0' /tmp/work/1/thumbnail.jpg
> ************************************************************
> If I run that command from the shell I get the same error.
> mytharchivehelper -t  "/tmp/work/1/stream.mv2" '0' /tmp/work/1/thumbnail.jpg
> John
Do you have any where you could upload a small sample file. It will be 
easier to find out whats happening if I can reproduce the problem for 
One thing you could try if you are using the compact theme is comment 
out the call to extractVideoFrame in the script (~ line 2857) and the 
script will skip the thumbnail grabbing and hopefully run to completion. 
It may just fail somewhere else though.

Paul H.

More information about the mythtv-users mailing list