[mythtv-users] SVN build: missing libmythfreemheg

Daris Drake darisd at hotmail.com
Sat Jun 3 20:21:24 UTC 2006

>Unfortunately, there are far to many possible causes to start guessing
>them.  So, my recommendation is to go back to as clean a system as you
>can get.  I.e. uninstall--even if "manually"--as much myth stuff from
>the system as possible (you can leave the database in place) and build
>from a clean checkout (not a "make clean" or "make distclean"--but a
>clean checkout) while making sure to follow the build instructions
>exactly and ensuring you've properly specified the QTDIR and that the QT
>bin directory is in the PATH.

Thanks Michael for the reply. Yeah I figured developers scanned both lists, 
but I was more than anything trying to get a response from someone who had 
experience with the SVN installation :)

I followed the procedure in the installation instructions to the letter. If 
QT is recognized, then why should I have to double check if QT is properly 
specified in the PATH? Sorry, I am just a bit confused what you are getting 
at with that one. Is there a version dependency?

I also checked the file dates on the compiled files in 
../mythtv/mythtv/libs/libmythfreemheg and they all match the date and time 
of the last make, so obviously make did not skip it. I see that it was 
installed to /usr/local/lib, so make install did not skip it either.

I just did a fresh checkout and make after uninstalling the YUM install of 
"mythtv-suite" which I had not removed before my first SVN make. I also 
deleted the binaries left from the YUM install. I get the same problem 
though. I checked the timestamp on the file in question and it shows the 
same as the other libraries (today, ten minutes ago).

Usind LDD, I still see that libmythfreemheg-0.19.so.0 is not found by 
mythbackend (or frontend for that matter).  So, excuse my ignorance to the 
inner workings of myth, but how do I see where mythbackend is looking for 
that library? Most other libraries listed in LDD for mythbackend are in 
/usr/lib64. I tried to make a link to this directory from the file in 
/usr/local/lib... same problem (with the same output for LDD). LDD for 
libmythfreemheg-0.19.so.0 shows no missing dependencies.

Would love more input, I am a pretty tenacious guy and would love to do some 
beta testing for the SVN builds if possible/necessary...

Daris Drake
darisd at hotmail.com

More information about the mythtv-users mailing list