[mythtv-users] Problem with yum

PAUL WILLIAMSON pwilliamson at mandtbank.com
Tue Jan 31 23:58:16 UTC 2006

>>> jarod at wilsonet.com 01/31/06 5:54 PM >>>
On Tuesday 31 January 2006 14:23, PAUL WILLIAMSON wrote:
>> and I'm getting this:
>> Error: Missing Dependency:
>> is needed by package rhn-applet
>> Error: Missing Dependency: /usr/lib/python2.3/site-packages/rpmdb
>> needed by package rhn-applet
>> I've tried installing rhn and rpm which should already be there.
>> I guess I'm not sure what yum is looking for...any ideas?
>Both of those are provided by the rpm-python package. Looks like your

>distro is either RHEL4 or FC3, no? (FC4 has python 2.4). If so, it
gets a 
>little tricky, as you may have both python 2.3 from Red Hat and python

>2.4 from ATrpms, and/or rpm from ATrpms, in which case, it might be a

>different package you need to provide the python 2.3 rpm bits...
>Personally, unless running true RHEL, I find the RHN applet to be a 
>big waste of time. Its badly broken on FC4 (and not fixed for FC5), 

I agree.  We run a batch of RHEL servers at work with a core rhn 
server.  Makes upgrading/patching really nice.  My piddly 4 
FC3 servers (good guess, btw) pale in comparison.

So, I guess I have two options - upgrade to FC4 or provide the 
2.3 bits.  Can I use yum, smart or apt to move to FC4, or can 
I use them to provide the python bits?


More information about the mythtv-users mailing list