[mythtv-users] mythtv hard lockup

Mike Dent mcdent at gmail.com
Thu Dec 21 09:52:04 UTC 2006

On 12/21/06, R. G. Newbury <newbury at mandamus.org> wrote:
> David Rees wrote:
> > On 12/18/06, Brad DerManouelian <myth at dermanouelian.com> wrote:
> >> I've also recently experienced the frontend becoming completely
> >> unresponsive. I can ssh in, but can't kill -9 the process. Even a
> >> reboot fails. I have to hit the reset button to get the machine back.
> >
> > That failure mode suggests an X/Nvidia problem to me, especially if
> > you are using OpenGL in your themes... can you confirm?
> I am not using OpenGl but I sometimes get frontend lockups if I attempt
> too many changes/presses on the remote. Particularly dangerous is
> attempting to go from rewind to forward, pr vice versa following an
> overshoot. The frontend locks solidly. NOTHING works, except the backend
> will happily continue to record programs and later examination shows
> that commflagging has run etc. etc...but it will be in the same state in
> the morning and only a 'big red switch' reboot will kill it. And the log
> shows NOTHING.
> I think that a race condition is triggered, as was discusse on the dev
> list recently. I think some code was patched in, but I am not sure of
> that, nor have I had a chance to see if the condition can now be
> replicated. I am on SVn 12265 IIRC... (Ohhh goody, I get to hit myself
> over the head trying to break it... My head that is!/

This seems to be exactly what is happening to me. I'm using 0.20
I'm testing the box with the plan to replace my Tivo but with these kind
of lock ups it won't be any time soon :(

> Geoff
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list