[mythtv-users] 0.20 crashing problem (newbie)

NathanKell nathankell at gmail.com
Sat Dec 16 22:21:16 UTC 2006

On 12/16/06, Brian Wood <beww at beww.org> wrote:
> On Dec 16, 2006, at 11:58 AM, NathanKell wrote:
> Some years ago I posted regarding a saa7134 tuner in FC3; our mythbox, with
> that and using 0.18, had been running pretty good (albeit the frontend
> crashed some, but never so destructively I felt like trying to fix it...);
> recently I took the plunge and upgraded to .20.
> First I tried a brand-spanking-new FC6 install; but that had the issue of
> the sound being muted on every channel change (so I used Neale Pickett's
> cronjob to unmute every 5 seconds). That worked, but the system locked up
> disturbingly often--which I thought might be related to that hack. So I went
> back to my FC3 setup, and did a dist-upgrade (since only update'ing mythtv
> kept erroring out). At first it worked fine, but recently it's been locking
> up again, with increasing frequency.
> So I'm here, begging for help. :]
> The lockup usually occurs during the night, which made me think it might
> have to do with mythfilldatabase, but that's set to run when zap2it tells it
> to, so it may not be run then. Unless it's a problem unrelated to mythtv, of
> course; but then, mythtv and its prereqs is all we run on the box...
> Now, I'm afraid I'm enough of a newb to not even really know what logs to
> check (or how) to see what might be relevant...
> Anyway, hoping for answers--or at least relevant questions that'll tell me
> what to look at... ;)
> Intermittent lockups are one of the more "fun" things to diagnose on a PC.
> They can be caused by any number of things, including power supplies, bad
> RAM, loose connectors and many other things.
> Without pretty expensive equipment the main method of troubleshooting is by
> substitution of suspected parts.
> My experience has been that a lot of such problems are caused by low-quality
> power supplies, especially the no-name types sold with inexpensive cases.
> I'd guess your problem has nothing to do with Myth, but rather your
> hardware. I would start by booting something like the the Universal Boot CD
> and running some diagnostics, I'd start with the RAM. Go to:
> http://www.ultimatebootcd.com/  To get the disk image.
> If you have bad RAM these tests will tell you. You can also test some other
> things.
> Make sure all connectors are tight. Best to remove and re-seat them rather
> than simply push them tight. Do this with your RAM and any PCI cards as
> well.
> Make sure your fans are working and that airflow is unimpeded. Clean all
> dust out of the case and any air filters. Thermal problems often cause the
> type of problem you describe.
> You might also find some useful info in the /var/log/messages file, but with
> this sort of problem it's unlikely.
> Good luck, but even experienced techs groan when a customer complaint starts
> out with "after it's been on for a while..." :-))

Well, yeah. But I'm (moderately) sure it's software at least, because
it's been stable for a year or more with .18. And while it locked in
FC6, it was stable again when I reverted from FC6 to FC3.
I mean, if it was just random lockyness, then yeah I'd start pulling
cards and stuff. I may be a -linux- newbie, but not so much PC. ;)

The one piece of hardware it could be is the new hard drive--I can try
swapping video partitions again and getting rid of LVM. But I'm kinda
doubtful that's it. Obviously can't hurt though..

Thanks, though!


More information about the mythtv-users mailing list