[mythtv-users] Intel mac mini linux, tv-out problems

emmanuel emansl at gmail.com
Thu Dec 14 02:05:59 UTC 2006

On 12/13/06, Matt Hannan <mythtvlist at cox.net> wrote:
> Jose Angel wrote:
> > I am involved in getting a Mythtv box with the new intel mac mini.
> > But, no success in the connection to an analog TV with no dvi connector.
> >
> > I have a dual boot system, with the standard Mac OSX + ubuntu edgy 6.10.
> >
> > Using my TFT monitor with the DVI-to-VGA adapter everything works ok
> > from the standard configuration (i only had to recompile kernel to
> > apply a patch for getting apple remote working).
> >
> > In order to connect to the analog TV, i have used the standar
> > dvi-to-(composite/s-video) apple adapter. When booting the macmini
> > connected to the TV, i can see in TV the menu of refit to choose
> > macosx or linux. When i select linux, the tv image goes off and
> > nothing happens.
> >
> > I am using xorg 7.1 (from the ubuntu repositories) and the latest git
> > i810 driver. I have tried several modifications in xorg.conf but i am
> > not an expert in modelines, 915resolution and so on....
> >
> > Any ideas?
> >
> > Thanks in advance!
> >
> > --
> > ______________________________________________
> > Jose Angel Alvarez
> >
> >
> I am impatiently awaiting the release of X11-7.2. Should have been
> released on Monday, but no dice yet.
> Everything I have read indicates that our issues SHOULD be fixed with
> that release.
> Fingers crossed.
> Let me know if you turn anything up in the meantime.
> Matt

It works with 7.1 provided the i810 driver is new enough. Note that it
takes a while for anything to show up on the screen. The Linux console
doesn't know how to output to the TV so it won't display anything
until X starts. Perhaps you're simply not waiting long enough.

BTW, don't bother with 915resolution for svideo out. It doesn't apply
here. Don't worry about adding modelines until there is something
output on your TV.


More information about the mythtv-users mailing list