[mythtv-users] Is this only me ?? Was 0.20 loves X too much

Henk Schoneveld belcampo at zonnet.nl
Mon Dec 11 16:09:12 UTC 2006

On Thursday 07 December 2006 16:51, mythtv-users-request at mythtv.org wrote:
> From: Henk Schoneveld <belcampo at zonnet.nl>
> Subject: [mythtv-users] 0.20 loves X too much
> To: mythtv-users at mythtv.org
> Message-ID: <200612071530.00590.belcampo at zonnet.nl>
> Content-Type: text/plain;  charset="us-ascii"
> Hi all,
> I think I notice that .20 isn't releasing memory after exiting. Made some
> comparisons between fixes of .19 and .20. Boot, log free -m, start
> Mythbackend, log free -m, start Mythfrontend go to Recordings page, log
> free -m, exit Mythfrontend, log free -m, stop Mythbackend, log free -m. If
> I do this with 0.19-fixes I get back all resources back. If I do exactly
> the same with 0.20-fixes I've lost 25-30MB which is 'happily' consumed by
> X. Both versions are compiled without OpenGL and use QTpainter.
> With the 0.20-fixes version after closing all down and starting for example
> firefox and then Mythbackend and Mythfrontend to the Recordings page, then
> exiting and shutting down Mythbackend and exiting firefox I tend to loose
> about the same amount of memory 25-30MB according to free -m.
> Any idea how to solve this ?
> I tried the above on 2 systems one with old XFree86 with 2.4.22 kernel and
> one with Xorg 6.9 with a 2.6.17 kernel. Systems do have other chipsets and
> different videocards.
> Henk Schoneveld

More information about the mythtv-users mailing list