[mythtv-users] xvmc can't play 720p content at 1080i

Daniel Walton dwalton at cisco.com
Thu Dec 7 02:21:08 UTC 2006

On Wed, 6 Dec 2006, Rick St. Pierre wrote:

> On 12/5/06, Daniel Walton <dwalton at cisco.com> wrote:
> > I have an older HDTV that doesn't support 720p so I need to play everything at
> > either 480p or 1080i.  I'm using XvMC and can playback 1080i content fine but
> > any 720p content gives my myth box fits (the audio stuters like crazy and the
> > video plays a little slow).  I see the following in the logfile:
> >
> ... cut logfile
> >
> > I searched the archives and found a few other people who have hit these errors
> > but not in the same scenario as me.  None of them posted a solution though.
> > Any ideas on how to fix this?  Is it a bug in myth or do I just not have enough
> > horsepower? I have a Athlon XP 2800, nvidia FX5200 running the latest drivers
> > (1.0-9629), running svn 12206.
> >
> I had similar problems, although just the prebuffering pauses when
> playing 720p on a 1080i output.  Unfortunately, I never solved the
> problem.  Well, I solved it by upgrading my system to one which
> doesn't require XvMC.  In my case it was always X that was gobbling up
> the CPU.  For me, it was intermittent and mainly watchable (although
> you could definitely see dropped frames watching sports).  I tried to
> get it working on an old VIA chipset socket A board with Fedora and a
> newer NForce2 board with Debian with the same results for both.  Your
> CPU should have enough horsepower .. I was using an XP 2000.
> Did you try the troubleshooting tips from the XvMC page on the wiki?
> That seems to have worked for some people.

yep..I actually added the last tip to the wiki :)  If I change my display to
480p then I can playback the 720p content with xvmc without any problems.


More information about the mythtv-users mailing list