[mythtv-users] Strange error: NVR: Can't open video device: /dev/video0

Preston Gallwas gallwapa at gmail.com
Tue Dec 5 06:50:25 UTC 2006

This is an inital mythtv setup that has never worked before


Linux sled10 #1 Tue Sep 19 07:26:15 UTC 2006 i686
i686 i386 GNU/Linux

HP DC530
PCTV USB2 (pinacle) using em28xx driver

Packages (from packman.unixheads.com)

libmyth0.20-10 i586
mythtv 0.20-10 i586
mythtv-backend 0.20-10 i586
mythtv-frontend 0.20-10 i586
mythtv-setup 0.20-10 i586
mysql 5.0.18-20.5 i586

After setting up mysql, I ran mythtv-setup

I configured the capture device as analog v4l capture card
/video device: /dev/video0
vbi device /dev/vbi
audio device /dev/dsp
audio sampling... none
default input television

The input can scan the channels just fine, so I think all is well.  I did
mythdatabasefill and it seemed to work great.

Mythbackend is running as root
as a test, I started mythfrontend as root from a terminal

When loading "Watch Live TV" the screen goes black, then waits, then returns
to the menu.  The frontend terminal screen says TV error: starterecorder()
-- timed out waiting for recorder to start

The backend error log says

 2006-12-04 21:05:30.779 TVRec(1): Changing from None to WatchingLiveTV
2006-12-04 21:05:30.803 TVRec(1): HW Tuner: 1->1
strange error flushing buffer ...
2006-12-04 21:05:32.107 NVR: Can't open video device: /dev/video0
open video:: Device or resource busy
2006-12-04 21:06:11.897 TVRec(1): Changing from WatchingLiveTV to None

Yet, when I do lsof | grep video0 nothing is using the device.

Can anyone point me in the right direction? I've been dinking with this for
5+ hours today now.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20061204/34bd8852/attachment.htm 

More information about the mythtv-users mailing list