[mythtv-users] Trying to get ittv and bttv cards working together.

Mark Paulus mark.paulus at verizonbusiness.com
Fri Dec 1 15:08:50 UTC 2006

DrTodd13 at comcast.net wrote:
> I have a working setup with an ittv (Hauppauge 350) tuner card connected to /dev/video0.
> I have another tuner card which is an ATI TV Wonder VE which is supported via the bttv
> driver.  When I tried to install the ATI card, it appears that the OS automatically recognized
> it (unlike the ittv card) and installed the driver for it.  At this point, I wanted to confirm that
> mythtv still worked and it didn't.  It seems that the bttv card got installed as /dev/video0 and
> the ittv card was moved to /dev/video1.  I tried the "using both ittv and bttv" section from
> Jarod's page and then realized maybe I needed to switch the 0 and 1 lines since OS
> decided to put bttv as video0 but still no luck.  Mythtvsetup says something like "Card 0...failed..."
> when I try to exit the program.
> I wasn't able to tune anything via xawtv with the bttv card either.  All I get is static.  Any
> suggestions?
> thanks,
> Todd
A bit more info would be helpful, since there could be different ways to 
attach your problem, depending upon your OS level.

I am running a Debian Sarge system with a 2.6.18 kernel from 
www.backports.org.  I have a bttv based card and an IVTV based card in 
one system, and they would initialize randomly, so one or the other 
would get /dev/video0 and /dev/video1 randomly.  I got around this issue 
by using customized udev rules which would create aliases for me, which 
I used in mythtv-setup.  So, now it doesn't matter which one is 
initialized first, as long as the alias is created correctly.

Here are my udev rules, and the script I created to support them:

$ cat /etc/udev/rules.d/z90bttv.rules
KERNEL=="video?", DRIVERS=="bttv",  PROGRAM="/usr/local/bin/v4ldev_namer 
bttv_vid", SYMLINK+="%c"
KERNEL=="vbi?", DRIVERS=="bttv",  PROGRAM="/usr/local/bin/v4ldev_namer 
bttv_vbi", SYMLINK+="%c"
KERNEL=="audio?", DRIVERS=="Bt87x", 
PROGRAM="/usr/local/bin/v4ldev_namer bttv_aud", SYMLINK+="%c"
KERNEL=="dsp?", DRIVERS=="Bt87x",  PROGRAM="/usr/local/bin/v4ldev_namer 
bttv_dsp", SYMLINK+="%c"
KERNEL=="adsp?", DRIVERS=="Bt87x",  PROGRAM="/usr/local/bin/v4ldev_namer 
bttv_adsp", SYMLINK+="%c"
me at mythtv2:/etc/udev/rules.d
$ cat /etc/udev/rules.d/z90ivtv.rules
KERNEL=="video?", ATTR{name}=="ivtv? encoder MPEG", 
PROGRAM="/usr/local/bin/v4ldev_namer ivtv", SYMLINK+="%c"
me at mythtv2:/etc/udev/rules.d
$ cat /usr/local/bin/v4ldev_namer

iam=`basename $0`
logger -t "$iam" "starting with $1"
files=`ls -1 /dev/${1}* 2>/dev/null`
for i in $files
if  [ -z $devnbr ]; then

logger -t "$iam" "returning ${1}${devnbr}"
echo ${1}${devnbr}

Once these are in place, then you can setup your cards to use the 
aliases:  ivtv_vid0; bttv_vid0/1 & bttv_aud0 or bttv_dsp0, or whatever.

If you are still having problems, you might want to post the portions of 
your dmesg that are between the
ivtv:  ==================== START INIT IVTV ====================
ivtv:  ====================  END INIT IVTV  ====================
and any that contain bt...

Mine looks like this:
ivtv:  ==================== START INIT IVTV ====================
ivtv:  version 0.8.2 (tagged release) loading
ivtv:  Linux version: 2.6.18-2-k7 SMP mod_unload K7 REGPARM gcc-3.3
ivtv:  In case of problems please include the debug info between
ivtv:  the START INIT IVTV and END INIT IVTV lines, along with
ivtv:  any module options, when mailing the ivtv-users mailinglist.
ivtv0: Autodetected Hauppauge card (cx23416 based)
ACPI: PCI Interrupt 0000:02:08.0[A] -> GSI 20 (level, low) -> IRQ 177
ivtv0: Unreasonably low latency timer, setting to 64 (was 32)
input: PS/2 Generic Mouse as /class/input/input2
b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded 
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
ts: Compaq touchscreen protocol output
ivtv0: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)
tveeprom 1-0050: Hauppauge model 26552, rev B268, serial# 7946856
tveeprom 1-0050: tuner model is LG TAPE H001F MK3 (idx 68, type 47)
tveeprom 1-0050: TV standards NTSC(M) (eeprom 0x08)
tveeprom 1-0050: audio processor is CX25843 (idx 37)
tveeprom 1-0050: decoder processor is CX25843 (idx 30)
tveeprom 1-0050: has radio, has no IR remote
ivtv0: Autodetected Hauppauge WinTV PVR-150
tuner 1-0043: chip found @ 0x86 (ivtv i2c driver #0)
tda9887 1-0043: tda988[5/6/7] found @ 0x43 (tuner)
tuner 1-0061: chip found @ 0xc2 (ivtv i2c driver #0)
cx25840 1-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #0)
cx25840 1-0044: loaded v4l-cx25840.fw firmware (14264 bytes)
wm8775 1-001b: chip found @ 0x36 (ivtv i2c driver #0)
ivtv0: Encoder revision: 0x02050032
ivtv0: Registered device video0 for encoder MPEG
ivtv0: Registered device video32 for encoder YUV
ivtv0: Registered device vbi0 for encoder VBI
ivtv0: Registered device video24 for encoder PCM audio
ivtv0: Registered device radio0 for encoder radio
tuner 1-0061: type set to 47 (LG NTSC (TAPE series))
ivtv0: Initialized Hauppauge WinTV PVR-150, card #0
ivtv:  ====================  END INIT IVTV  ====================

$ dmesg | grep bt
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:02:09.0, irq: 185, latency: 32, mmio: 
bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012
bttv0: using: Pinnacle PCTV Studio/Rave [card=39,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffefff [init]
tuner 3-0043: chip found @ 0x86 (bt878 #0 [sw])
tuner 3-0060: chip found @ 0xc0 (bt878 #0 [sw])
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: pinnacle/mt: id=5 info="NTSC / mono" radio=no
bttv0: using tuner=33
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video1
bttv0: registered device vbi1
bttv0: PLL: 28636363 => 35468950 .. ok
bttv0: PLL can sleep, using XTAL (28636363).


-------------- next part --------------
A non-text attachment was scrubbed...
Name: mark.paulus.vcf
Type: text/x-vcard
Size: 296 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20061201/aa223152/attachment-0001.vcf 

More information about the mythtv-users mailing list