[mythtv-users] ImageMagick dependency

Shanon Mulley shanonmulleyster at gmail.com
Thu Aug 31 23:32:02 UTC 2006

On 8/31/06, Shanon Mulley <shanonmulleyster at gmail.com> wrote:
> On 8/30/06, Michael T. Dean <mtdean at thirdcontact.com> wrote:
> > On 08/30/06 01:12, Shanon Mulley wrote:
> >
> > >A little background before I get to my question (You can skip to the
> > >last sentance if you just want the question)...
> > >I use ImageMagick for a non-mythtv related task on my box. Up until
> > >just recently, it has worked just fine with the the version of
> > >ImageMagick that is installed via yum/smart (I use Fedora Core 5).
> > >Recently, the ImageMagick bit has started having problems (I'll leave
> > >out the details - this is probably the wrong forum for that).
> > >
> > >Now, I have been able to reproduce and fix this problem in a test
> > >environment (VMWare) by installing the most recent version of
> > >ImageMagick. However, when I tried to install mythtv on this test
> > >environment (Usuing the FC5 yum install), it wouldnt work, because I
> > >beleive it needs the correct version of ImageMagick installed.
> > >
> > So, is this just a package-manager error or did the install work and
> > Myth fail?
> >
> > Mike
> Well
> 1) My myth box right now, with the standard mythtv installation from
> repositries (FC5 - from updates) works fine. The ImageMagick it
> installs does not work fine. (It stopped working a few weeks back).
> 2) When I try to install a recent version of ImageMagick manualy (via
> rpm), it tells me it will have to uninstall mythtv-suite, as I am
> removing something it is dependant on (the older version of
> ImageMagick). I stop it at this point (I dont want to lose my precious
> mythtv)
> 3) When I try to install mythtv via yum on my test environment (which
> has a working, recent version of ImageMagick it installed manually via
> rpm) it fails, as it is unable to resolve some dependancies (Involving
> ImageMagick).
> So I guess neither - the package manager is doing its job (it is
> telling me mythtv will disapear if I install ImageMagick manually),
> and mythtv is still working, cause I heeded the package managers
> warnings. (But I'm sure it would have failed if I didnt heed its
> warning).
> Shanon.

I managed to sort it all out in the end.

What was causing me problems was ImageMagick- I
went to the repository site, and downloaded
ImageMagick- (The prior version - luckily it was
still there), along with the matching ImageMagick-perl rpm. Manually
downgraded, and now everything is happy. Now I just have to make sure
I dont accidently upgrade it again.

More information about the mythtv-users mailing list