[mythtv-users] Can't solve a problem with Skipping/Fast Forwarding

Stephen Robertson stephengrobertson at gmail.com
Thu Aug 17 12:53:14 UTC 2006

The thing that is weird is that new recordings don't seem to work.  If
I start recording something and then start watching it while it is
recording then I can FF/REW okay.  If I stop the recording and then
watch it again then the problem returns.

I'd decided to scrap my database and start again even though
mysqlcheck seemed to think everything was okay.  However I had a
change of heart and decided to restore the database.  When I try to do
this it appears that there are still problems as some of the INSERT
statements have recordedseuk instead of recordedseek and some other
similar funnies.  Whether this indicates some corruption or not I'm
not sure.  So I was going to try removing all the inserts into this
table and then try restoring that and then try running mythcommflag
--rebuild.  If i'm understanding correclty this would then repopulate
the recordedseek table.

On 8/17/06, Michael T. Dean <mtdean at thirdcontact.com> wrote:
> On 08/16/2006 03:30 AM, Stephen Robertson wrote:
> >>Corrupted database?  I recommend running optimize_mythdb.pl (and setting
> >>it to run in a daily cron job) and then running "mythcommflag --rebuild"
> >>on one of the affected recordings. If that clears up the skipping
> >>issues, repeat the mythcommflag on any other recordings as required.
> >>(Don't know how it will affect FFWD/REW, but if it fixes skipping, it
> >>needs to be done.)
> >>
> >Thanks very much for that.  I've tried doing this, to be honest hadn't
> >used either of those before.  Unfortunately doesn't seem to have
> >solved the problem.  I would say that the FF/REW seems to be "better"
> >in that I think that it is actually moving backwards and forwards
> >through the recording, but the video is still stuck cycling around a
> >few frames.  I also tried this on a recording from a commercial free
> >channel and it exhibits the same problem, both before and after trying
> >your suggestions.
> >
> That means that your DB is no longer corrupt (new recordings should work
> fine), but you need to fix the seektable for old recordings.  In other
> words, your "mythcommflag --rebuild" commands didn't work (i.e. you had
> incorrect options or something).  Let us know what exactly you did and
> we'll let you know what to do differently.
> Mike
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list