[mythtv-users] Alsa SPDIF SP13000 (via8237)

Robin Gilks g8ecj at gilks.org
Mon Aug 14 07:29:10 UTC 2006

> On 14/08/06, Robin Gilks <g8ecj at gilks.org> wrote:
>> >
>> > For the Via8237, it's device 0, subdevice 3.
>> >
>> > Mike
>> As stated, I've tried all combinations - I inferred that it was in fact
>> 0,0,3 by using the -v flag on "aplay -D spdif ..." but that doesn't
>> explain why
>>   aplay -D spdif xxx.wav
>> works OK but
>>    aplay -D hw:0,0,3 xxx.wav
>> doesn't work. Must be missing something (again!)
> Shouldn't that be:
> aplay -D hw:0,3 xxx.wav

Oh no no no - If you looked at the output of aplay -l I posted you'll see
that card 0 has 2 devices 0 & 1 and that device 0 has 4 subdevices 0-3.
The numbering is card.device.subdevice. Not that it makes any difference
because it still don't work!! (except that "aplay -D hw:0,3 xxx.wav"
results in "aplay: main:547: audio open error: No such file or directory"
which of course is right - it doesn't exist)

> Curiously, what is the output of
> cat /proc/asound/pcm

Here you go Nick

# cat /proc/asound/pcm
00-00: VIA 8237 : VIA 8237 : playback 4 : capture 1
00-01: VIA 8237 : VIA 8237 : playback 1 : capture 1

>> I've seen some chatter about assigning PCM to SPDIF using alsamixer but
>> there are no toggles that I can see that allow a selection to take
>> place.
>> I'll try the command
>>    amixer set 'IEC958 Playback AC97-SPSA' 0
>> when I get home tonight to see if the assignment has to be done
>> manually.
> On my master system (using NForce3 Ultra board, sound is NVidia CK8S)
> I have a control called "IEC958 Playback Source" which is set to PCM
> (the other options are analog in and SPDIF in). "IEC958 Playback
> AC97-SPSA" is set to 100% and "IEC958" is enabled.
> Your asound.conf (or .asoundrc) can be as simple or complicated as you
> require. I don't think the definitions in /usr/share/alsa/cards can
> just be dropped in as they reference other config files. I would
> suggest (sorry if you have already tried this) either start from the
> beginning with the ALSA docs
> (http://www.alsa-project.org/alsa-doc/doc-php/asoundrc.php?module=via82xx)
> or drop in Mike's detailed asoundrc example from the MythTV wiki (and
> amend for your setup).

Thats where I started but I can't amend it to use a device that doesn't
work!! (or at least not to get anywhere).

Comparing it to my nvidia onboard sound on my server box, that has a
toggle in alsamixer to connect analog to the iec958 port but the via8237
doesn't. In fact the nvidia output for alsa is totally different (and much
more verbose) that the via chip. I guess alsa is just broken for this
sound device:-(

I wonder if this is related to the fact that I'm running an old 2.6.13
kernel because of bugs in recent ivtv drivers prevents me from upgrading
(external audio input is dodgy after ivtv-0.4.0). Thinks....

I'll try booting a later kernel tonite after wifey has watched all she
wants and at least try and get aplay to play!!

Robin Gilks

More information about the mythtv-users mailing list