[mythtv-users] Alsa SPDIF SP13000 (via8237)

Nick knowledgejunkie at gmail.com
Mon Aug 14 07:09:16 UTC 2006


On 14/08/06, Robin Gilks <g8ecj at gilks.org> wrote:
> >
> > For the Via8237, it's device 0, subdevice 3.
> >
> > Mike
>
> As stated, I've tried all combinations - I inferred that it was in fact
> 0,0,3 by using the -v flag on "aplay -D spdif ..." but that doesn't
> explain why
>   aplay -D spdif xxx.wav
> works OK but
>    aplay -D hw:0,0,3 xxx.wav
> doesn't work. Must be missing something (again!)

Shouldn't that be:

aplay -D hw:0,3 xxx.wav

Curiously, what is the output of

cat /proc/asound/pcm

> I've seen some chatter about assigning PCM to SPDIF using alsamixer but
> there are no toggles that I can see that allow a selection to take place.
> I'll try the command
>    amixer set 'IEC958 Playback AC97-SPSA' 0
> when I get home tonight to see if the assignment has to be done manually.

On my master system (using NForce3 Ultra board, sound is NVidia CK8S)
I have a control called "IEC958 Playback Source" which is set to PCM
(the other options are analog in and SPDIF in). "IEC958 Playback
AC97-SPSA" is set to 100% and "IEC958" is enabled.

Your asound.conf (or .asoundrc) can be as simple or complicated as you
require. I don't think the definitions in /usr/share/alsa/cards can
just be dropped in as they reference other config files. I would
suggest (sorry if you have already tried this) either start from the
beginning with the ALSA docs
(http://www.alsa-project.org/alsa-doc/doc-php/asoundrc.php?module=via82xx)
or drop in Mike's detailed asoundrc example from the MythTV wiki (and
amend for your setup).

Nick

-- 
MythTV Official wiki:
http://mythtv.org/wiki/
MythTV users list archive:
http://www.gossamer-threads.com/lists/mythtv/users


More information about the mythtv-users mailing list