[mythtv-users] fork failed, cannot allocate memory in mythvideo/mythdvd

Tristan De Groof tristandegroof at evonet.be
Wed Aug 9 09:05:53 UTC 2006


since I installed an nvidia AGP card (mx4000) in place of an older ATI
radeon 7000 pci (the radeon driver had problems with the DVI-output, and
the ati one doesn't recognize such old cards), i regularly encounter the
following error in mythvideo and mythdvd:

myth_system():Error, fork() failed because Cannot allocate memory

Both mythvideo and mythdvd are configured to use xine as player. This
error always comes up when I try to start a video (avi), but only shows
when starting a dvd when I have tried (and failed because of the above
fork error) to start a video (avi) before. The amount of system memory
hasn't changed, and I memtested it, so there's nothing wrong with the
memory itself. When i start xine outside of myth, i have no problem
whatsoever. I also tried replacing xine with mplayer, but this doesn't
change a thing. The system runs Kubuntu Dapper, with mythtv 0.19. Does
anybody have an idea where this error is coming from?


More information about the mythtv-users mailing list