[mythtv-users] [OT] DVB Diseqc trouble - please help!

Jakob Fix jakob.fix at gmail.com
Thu Apr 6 22:52:39 UTC 2006

[I don't know where to post this question, and hope somebody here can
point me to a more appropriate list, or better still, help me find the

I have a satellite dish with a dual LNB, Astra 19 (LNB 0) and Astra 28
(LNB 1).  Until recently, both worked fine.  Then I tried to upgrade
to .19, and since then the second LNB "stopped working", ie. a simple
szap produced this

$ szap "BBC 1 Wales"
reading channels from file '/home/mythtv/.szap/channels.conf'
zapping to 506 'BBC 1 Wales':
sat 0, frequency = 10802 MHz H, symbolrate 22000000, vpid = 0x0900,
apid = 0x0902
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
status 01 | signal d9c2 | snr 73fb | ber 0000fff0 | unc 00000000 |
status 01 | signal c7da | snr 9399 | ber 0000fff0 | unc 00000000 |
status 01 | signal d1d5 | snr 8bfb | ber 0000fff0 | unc 00000000 |

No FE_LOCK. BTW, I don't know why it says "sat 0" at the beginning of
the third line (but see further down).  None of the channels on Astra
28 can be szapped, but Astra 19 is fine.

So I did a DVB scan, like this
(-s 1 for the second LNB, -t 1 for TV only, and the file as seed data):

$ scan -s 1 -t 1 /usr/share/doc/.../scan/dvb-s/Astra-28.2E > mychannels.conf

which took between 5 and 10 minutes and produced a nicely filled list
of channels (in the 1300), and had diagnostic output like this:

scanning /usr/share/doc/dvb-utils/examples/scan/dvb-s/Astra-28.2E
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 10773000 H 22000000 5
>>> tune to: 10773:h:1:22000
0x07fd 0x18ae: pmt_pid 0x0000 BSkyB -- CBeebies (not running)
0x07fd 0x18af: pmt_pid 0x0000 BSkyB -- BBC THREE (running)
0x07fd 0x18bb: pmt_pid 0x0000 BSkyB -- BBC 1 NI (running)
0x07fd 0x18db: pmt_pid 0x0000 BSkyB -- BBC R Cymru (running)
0x07fd 0x189d: pmt_pid 0x0105 BSkyB -- BBC 1 London (running)
0x07fd 0x189e: pmt_pid 0x0107 BSkyB -- BBC 2 England (running)
0x07fd 0x18a0: pmt_pid 0x0109 BSkyB -- BBC NEWS 24 (running)
0x07fd 0x18a2: pmt_pid 0x010a BSkyB -- ETV (running)
0x07fd 0x18a4: pmt_pid 0x0000 BSkyB -- BBC TES Test (not running)
0x07fd 0x18a5: pmt_pid 0x0000 BSkyB -- BBC TES 2 (not running)
0x07fd 0x18ab: pmt_pid 0x0108 BSkyB -- BBC TES 3 (running)
0x07fd 0x18ac: pmt_pid 0x010b BSkyB -- BBC FOUR (running)
0x07fd 0x18ad: pmt_pid 0x0000 BSkyB -- CBBC Channel (not running)
Network Name 'ASTRA'

This looks encouraging, doesn't it? However, when I do a szap, like this

$ szap -c mychannels.conf "BBC 1 London"
reading channels from file 'mychannels.conf'
zapping to 1 'BBC 1 London':
sat 1, frequency = 10773 MHz H, symbolrate 22000000, vpid = 0x1388,
apid = 0x1389
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
status 02 | signal 0058 | snr 424e | ber 0000fff0 | unc 00000000 |
status 00 | signal 0000 | snr 6e19 | ber 0000fff0 | unc 00000000 |
status 00 | signal 0005 | snr 684c | ber 0000fff0 | unc 00000000 |

Never got a FE_LOCK. I noticed it's now "sat 1" in the first position
of the output, but it doesn't work either.

Obviously, I had the same tuning problem when trying to set up mythtv.
 I would really like to find a solution to this, even if it is just so
that the wife can watch "Gardener's World" again. :-)

Thanks in advance for your input.

More information about the mythtv-users mailing list